support modern cryptographic methods

Advertisement

Advertisement

Bottswana
Guest

Support for ed25519 keys

Hello folks,

I found this post about ed25519 here: https://winscp.net/forum/viewtopic.php?t=14731
PuTTY has added support for ed25519 and ecdsa in it's snapshot channel. Is it possible to get a build of WinSCP with this support?
I had a look at it myself but the changes to the dev build over the current codebase in WinSCP are more than I anticipated.

Thanks

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,459
Location:
Prague, Czechia

Re: Support for ed25519 keys

We do not plan to upgrade to dev code of PuTTY. We typically wait for an official release.

Reply with quote

Bottswana
Guest

Is it possible to do a dev code release? I have no worries with compiling WinSCP, but I use ed25519 keys and WinSCP not being able to take them is frustrating. The intergration of PuTTY into WinSCP is a little out of my skillset.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,459
Location:
Prague, Czechia

mvs wrote:

Hello!
PuTTY was released 0.65 some time ago. Do you plan to make support of ed25519 keys and other modern cryptographic methods? For now isn't possible to connect to some servers from WinSCP and Netbox (Far Manager plugin https://github.com/michaellukashov/Far-NetBox/)
But Ed25519 is not in PuTTY 0.65.

Reply with quote

Advertisement

You can post new topics in this forum