Scripting issue in Version 5.7 (Build 5125)

Advertisement

benzenet
Guest

Scripting issue in Version 5.7 (Build 5125)

Hi I have updated the WinSCP from 5.5.4 (Build 4433) to 5.7 (Build 5125). For most of the ftp servers my vbs connect to are working fine with the latest update. However, I noticed this one ftp server is having problem downloading using the "get" command in batch mode. I keep getting the following issues:
    -Can't get attributes of file
    -Could not retrieve file information
    -SIZE not allowed in ASCII mode

I also tested the same script using the previous version I have (v5.5.4) and it works fine. Is there some fundamental change to the "get" command for the latest version that causes this behavior? I have also attached the log files from both test for your reference.

ps Personal information such as URL, user account, file names, were replaced with angle brackets (<>) in the log file.

Thank you for your help!
  • log_build_4433.txt (8.25 KB, Private file)
Description: Log from build 4433 (success download)
Description: Log from build 5125 (failed download)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: Scripting issue in Version 5.7 (Build 5125)

benzenet wrote:

Is there some fundamental change to the "get" command for the latest version that causes this behavior?
It's this change:
https://winscp.net/tracker/1209

While your server claims support for SIZE command, its implementation seems to be limited to binary mode, what WinSCP does not expect.

This issue has been added to the tracker:
https://winscp.net/tracker/1292

Can you send me an email, so I can send you back a development version of WinSCP once I implement a solution for this? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

benzenet
Joined:
Posts:
1
Location:
Chicago

Hi Martin,
Thank you for your response. I sent you an email few minutes ago.

An off topic question: I missed an "n" when I created this user account. How do I change it from "bezenet" to "benzenet"?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Got your email.
I've changed your username.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum