Error folder does not exist

Advertisement

Exsiteit
Joined:
Posts:
3
Location:
Sacramento, California, USA

Error folder does not exist

My Hard Drive failed recently. So now when I start WinSCP I get an error that the folder does not exist. Is there anyway to reset the winscp.ini file without deleting all my usernames and settings from WinSCP?

Windows 8.1
WinSCP 5.7 (Build 5125)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Error folder does not exist

So what is the error message exactly like?
_________________
Martin Prikryl

Reply with quote

Exsiteit
Joined:
Posts:
3
Location:
Sacramento, California, USA

Error folder does not exist

I am attaching a screenshot. The user TKOP no longer exists so it can't find the file.

Error.jpg

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Error folder does not exist

That's probably because initial local directory of a saved site does not exist:
https://winscp.net/eng/docs/ui_login_directories

If you have Remember last used directory session option enabled (see the link above), the problem goes away after the first connection.
If not, you can remove the path in Login dialog.

If you need to do it for all saved sites, you can use:

winscp.exe /batchsettings * LocalDirectory=b:\existingdir

See https://winscp.net/eng/docs/commandline#batchsettings

Reply with quote

Advertisement

Nitrofx
Guest

Re: Error folder does not exist

martin wrote:

That's probably because initial local directory of a saved site does not exist:
https://winscp.net/eng/docs/ui_login_directories

If you have Remember last used directory session option enabled (see the link above), the problem goes away after the first connection.
If not, you can remove the path in Login dialog.

If you need to do it for all saved sites, you can use:

winscp.exe /batchsettings * LocalDirectory=b:\existingdir

See https://winscp.net/eng/docs/commandline#batchsettings

am having a similar issue, I have tried the sugested workarounds to not avail. The error am seeing is very similar and happens when starting the application. no sites have been added and the all the configuration files have been removed from the system.

Untitled.png

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Error folder does not exist

Nitrofx wrote:

am having a similar issue, I have tried the sugested workarounds to not avail. The error am seeing is very similar and happens when starting the application. no sites have been added and the all the configuration files have been removed from the system.
Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

You can post new topics in this forum