BUG report: sym links not refreshed between sessions

Advertisement

khoffman
Guest

BUG report: sym links not refreshed between sessions

Ok, didn't see a report of this behavior which looks like a bug to me.

I have a sym link to a directory I use a lot. It is just a trick to get deep in a directory tree to my current workspace. The sym link worked fine in WinSCP. Then I moved the symlink to target a directory one level lower. Works fine in SeccureCRT but in WinSCP, clicking the symlink still goes to the same location that the link orginally pointed to. Since it was only a minor issue, I didn't worry about it. The behavior persisted through many sessions of WinSCP. Finally, I looked at the properties of the file in WinSCP. The properties listed the correct sym link target (ie not the one that WinSCP actually went to). I then hit refresh and clicked the sym link and it went to the correct location 1 directory level lower in the tree.

Thanks for the great product. Hope this helps.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,093
Location:
Prague, Czechia

It is not a bug, it is feature :-)

The affect of entering the directory is optionally cached permanently. You may turn this off on Directories tab o Login window.

You may clean cache for one directory by reloading it. To clean cache for whole server, use Commands/Clean Caches.

Note that WinSCP does not use the resolved path of the symlink when changing directories, it is the server who decides the target path.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum