Topic "Access to unexisting "Images" folder causes error"

Author Message
alessiocanepa

Guest


i'm using version 5.7.2.
windows 7 - italian
Using "kepp remote directory up to date" i set as local directory "C:\Users\Alessio\Documents".
When the sync starts it automatically tries to access "C:\Users\Alessio\Documents\Immagini" (where immagini is the italian word for images). But that folder does not exist. it gives error 5 and stops syncing.
Any idea?
alessiocanepa

Guest


I discovered that's a bug of windows. when listing directories contained in Documents using the code, it appears "Immagini" (or the correspondent in another language). That folder "exists" even if it is not displayed in the explorer interface. If you manually tipe its path in explorer, it says that you don't have permissions to access that folder (even if you are admin). When WinSCP then tries to access it, it gets access denied.

I solved the problem deleting that unuseful folder from command line.

Anyway, WinSCP should not block in case of access denied, but log it and continue.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
alessiocanepa wrote:
Anyway, WinSCP should not block in case of access denied, but log it and continue.

See Continue on error option:
https://winscp.net/eng/docs/ui_keepuptodate
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License