Topic "Add session/site name to Patterns to pass to Putty/Kitty"

Author Message
braykov
[View user's profile]

Joined: 2013-02-12
Posts: 88
Hi,
I am using Kitty with WinSCP like this:
Code:
kitty.exe -title !U@!@ -cmd "cd '!/'" !U@!@

However I would like my kitty title to have the name of the session that I am opeing - currently I can only pass session hostname, username, etc.
This way when I have multiple sessions open in WinSCP I can have multiple Kitty sessions and the names will match the tabs in WinSCP.
Currently I am making errors, entering commands in one window thinking it is a totally different session.
The session param could be !S and an example terminal client path could be:
Code:
kitty.exe -title !S -cmd "cd '!/'" !U@!@
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
OK, good idea. Will consider it.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
This request has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1346

I'm sending you a development version for testing.
braykov
[View user's profile]

Joined: 2013-02-12
Posts: 88
OK, I tested it.
The pattern list did not show any new patterns, but I assumed you implemented !S.
So I tried it and my title showed like this:
Code:
sftp://<username>:<password>@<IP>/

The idea was for !S to just provide the session name. The name that is showed in the tab caption and in the Login window (the left-side tree).
Furthermore, the password presented now, points a security concern.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
The new patterns are
!# - port number
!N - session name
braykov
[View user's profile]

Joined: 2013-02-12
Posts: 88
Hi,
I would like to report a problem with this feature - using the test version that you sent me.

If the session name has a space in it, then Kitty fails to open with an error:
Code:
Unable to open connection to
-
Host does not exist


I suppose when constructing the string for the !N parameter you need to use double quotes.
I hope this helps and gets fixed for the new version Wink
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
I assume that using "!N" would help, right?
braykov
[View user's profile]

Joined: 2013-02-12
Posts: 88
Yes, it works that way. But it is not that logical for a user to come up with this solution.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
That's consistent with other patterns and even with how a variable resolution works in Windows shell (or even *nix shell).
RomanLangenbourg

Guest


prikryl wrote:
The new patterns are
!# - port number
!N - session name


I'm using Super Putty and usually I have not default port. But I can't pass it to SP - so connection refused and I need every time run it manually. Super time consuming and boring. Please, give pattern for port number.

Thanks a lot!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License