Cannot change type of transfer (binary/ascii)

Advertisement

dingodave
Guest

Cannot change type of transfer (binary/ascii)

I've downloaded and installed the latest version (3.6.8 build 245) and I can't seem to change the type of transfer between automatic, binary, and ascii.

This is causing my programs to fail, since it's not handling the ascii files correctly.

I've modified it in the settings to automatic, and made sure the ASCII transfer type list had the file type (*.prop). But when I go to drag n drop between the two panels from local to remote, the copy dialog shows the transfer types as greyed out, and is set to binary, no matter what I set the preferences to..

Please help!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: Cannot change type of transfer (binary/ascii)

The transfer mode selector is disabled when the ASCII (text) mode would have no effect. I.e. when local and remote computer uses the same end-of-line sequnce, i.e. when the server uses Windows sequence.

EOL sequence for server can be configured on Environment tab of Login window.

So, for SCP protocol you will have the selector disabled whenever you select Windows sequence (13/10). For SFTP protocol the same is true as long as the latest SFTP protocol version supported by the server is 3. From 4 up the selector is enabled always due to native support for ascii (text) mode transfers by the server.
_________________
Martin Prikryl

Reply with quote

dingodave
Guest

Re: Cannot change type of transfer (binary/ascii)

I should have said, I'm using WinSCP on a Windows XP box, but transferring to a Linux server... I would think that the ASCII transfer would have to be enabled, since the line endings are different???

Thanks for your help!

Reply with quote

dingodave
Guest

Re: Cannot change type of transfer (binary/ascii)

Never mind! I got it.. Just had to think differently! :oops:

I thought the line ending setting in the Environment panel was for the local machine, not the server. Once I changed that to Unix (LF), it worked perfectly... Sorry about that!

Reply with quote

Advertisement

You can post new topics in this forum