How to go thru interactive ssh gw.

Advertisement

[HEJ]
Guest

How to go thru interactive ssh gw.

Hi,

I tried all combination of posts I read about ssh forwarding, but could not find the answer to my case.
Situation (using winscp 3.6.8 b245): MYcomp. -> interactive ssh GW -> Target server.
By 'interactive' I mean it asks from me where to connect, what protocol ("What kind of connection? [1 = telnet, 2 = ssh (default)]") to go on further, what username to use for target.
In putty I connect via ssh to this GW, then fill in the lines interactively.

How can I set this GW in winSCP?
Using a SCP shell command "hostname\n2\nusername\n" DID not succeeded in feeding the lines;
"ssh hostname" command neither worked.

Some log snippets follows (cutted confidential parts):

. WinSCP Version 3.6.8 (Build 245) (OS 5.0.2195 Service Pack 4)

. User name: none (Password: No, Key file: No)
. Transfer Protocol: SCP
. SSH protocol version: 2; Compression: No
. Agent forwarding: Yes; TIS/CryptoCard: No; KI: No; GSSAPI: No
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping type: -, Ping interval: 30 sec; Timeout: 15 sec
. SSH Bugs: -,-,-,-,-,-,-,-,
. Proxy: none
. Return code variable: Autodetect; Lookup user groups: No
. Shell: ssh <confidential>, EOL: 0
. Local directory: default, Remote directory: home, Update: No, Cache: Yes
. Cache directory changes: Yes, Permanent: Yes
. Clear aliases: No, Unset nat.vars: No, Resolve symlinks: Yes
. Alias LS: No, Ign LS warn: No, Scp1 Comp: No

. Successfully started encryption
. Sent username "none"
. Remote dLogin permitted without a password because the account has no password.
. Authentication successful
. Started session
. --------------------------------------------------------------------------
. Using SCP protocol.
. Doing startup conversation with host.
. Skipping host startup message (if any).
> echo "WinSCP: this is end-of-file:0"
! Can't open -c: No such file or directory
! Can't open ssh <censored target server ;)>: No such file or directory
. Waiting for data timed out, asking user what to do.
. Asking user:
. Host hasn't answered for 15 seconds.
.
. Wait for another 15 seconds? Pressing 'Abort' button will close session. ()
. Attempt to close connection due to fatal exception:
* Terminated by user.
. Closing connection.
* (ESshFatal) Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).
* Terminated by user.


Maybe this part is especially relevant to my case:
"> echo "WinSCP: this is end-of-file:0"
! Can't open -c: No such file or directory"
What is this echoing file, and where to set (non)skipping startup messages?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,599
Location:
Prague, Czechia

Re: How to go thru interactive ssh gw.

I do not think it is possible to pass interactive gateway with WinSCP. I'm sorry.
_________________
Martin Prikryl

Reply with quote

Guest

Re: How to go thru interactive ssh gw.

martin wrote:

I do not think it is possible to pass interactive gateway with WinSCP. I'm sorry.

And how about pre-feeding the lines somehow like SCP shell command using answer + \n escape sequences ?

Reply with quote

David D.
Guest

Re: How to go thru interactive ssh gw.

I have cygwin with ssh installed on my local PC. Additionally, the runhide program dose nothing more then execute what is passed to it in a hidden window, so the bash shell is hidden from view.

The following is the target of a MS Windows shortcut that creates a ssh tunnel from my local PC through a gateway server to a target server.

%SystemDrive%\cygwin\usr\local\bin\runhide.exe bash.exe -c 'ssh -f -L 9002:TargetServer:22 GatewayServer tail -f /dev/null;"C:\Program Files\WinSCP3\WinSCP3.exe" scp://me@localhost:9002;exit'

The pertinent information is the following two statements:

ssh -f -L 9002:TargetServer:22 GatewayServer

"C:\Program Files\WinSCP3\WinSCP3.exe" scp://me@localhost:9002

The only "issue" with this is that the title bar has "me@localhost - WinSCP". Is there a way to override the title bar with something like "TargetServer WinSCP"?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,599
Location:
Prague, Czechia

Re: How to go thru interactive ssh gw.

David D. wrote:

The only "issue" with this is that the title bar has "me@localhost - WinSCP". Is there a way to override the title bar with something like "TargetServer WinSCP"?
I do not understand why you need it. But you may achieve it by storing session settings under the wanted name ("TargetServer") and using the name instead of "me@localhost" as command-line parameter.
_________________
Martin Prikryl

Reply with quote

David D.
Guest

Re: How to go thru interactive ssh gw.

martin wrote:

I do not understand why you need it...

Martin,

Your advice worked exactly as I had hoped it would. Thank you.

This request wasn't a requirement, but just a convenience issue. When opening several instances of WinSCP to different servers, it is convenient to have an accurate title label (i.e. not me@localhost).

Reply with quote

Advertisement

You can post new topics in this forum