BUG in preferences in "External Applications" field

Advertisement

WFX
Joined:
Posts:
4

BUG in preferences in "External Applications" field

Hi !

I have the last version of WinSCp (3.7.1).
In "Preferences"=>"Integration"=>"External Applicatios"=>"Putty path" when you have a path containing a " " (space caracter), and you press "CTRL+P" to launch putty, you get an error : "File not found".
It cuts the string path at the first " " (space caracter).

I think that you have to store the putty path between "" to keep spaces.

WFX

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: BUG in preferences in "External Applications" field

WFX wrote:

I think that you have to store the putty path between "" to keep spaces.
No, I think that YOU have to include path between "" :-)
I believe that if you select the putty.exe file using "..." button, it is already enclosed in quotes, is'n it? Let me know.

Note that you may add some command-line options after the path. So without quotes around path, WinSCP would not be able to decide what is space in path and what is space separating command-line parameters.
_________________
Martin Prikryl

Reply with quote

WFX
Joined:
Posts:
4

Yes, you're right when you select it with the '...' button, the path is enclosed with "", and it's working fine.

But next time you open WinSCP, "" are gone (not stored in .INI file) ;)
So if you press "CTRL+P", that doen't work and you have to open again the panel, to add "" or select again the file...

WFX

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

WFX wrote:

But next time you open WinSCP, "" are gone (not stored in .INI file) ;)
You are right! Thanks for letting me know :-(

Some workarounds until I fix this:
- use registry instead of INI file to save your configuration
- or use short path name instead of long one. I.e. c:\progra~1\putty\putty.exe instead of "c:\program files\putty\putty.exe"
- or add space after the trailing quote, i.e. "c:\program files\putty\putty.exe"<space>
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum