WinSCP 3.7.2 Error

Advertisement

kurt
Guest

WinSCP 3.7.2 Error

Hi, I have problems with winscp through proxy connection. The error message is: Invalid access to memory.

Here is the log:
. --------------------------------------------------------------------------
. WinSCP Version 3.7.2 (Build 262) (OS 5.0.2195 Service Pack 4)
. Login time: Montag, 31. Januar 2005 10:49:15
. --------------------------------------------------------------------------
. Session name: Home Compression
. Host name: *****.homeip.net (Port: 443)
. User name: ***** (Password: Yes, Key file: No)
. Transfer Protocol: SCP
. SSH protocol version: 2 only; Compression: Yes
. Agent forwarding: No; TIS/CryptoCard: No; KI: Yes; GSSAPI: No
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping type: N, Ping interval: 60 sec; Timeout: 15 sec
. SSH Bugs: -,-,-,-,-,-,-,-
. SFTP Bugs: -,-
. Proxy: HTTP
. HostName: fmsproxy2 (Port: 3128); Username: ; Passwd: No
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: /bin/sh, EOL: 0
. Local directory: E:\, Remote directory: /cygdrive, Update: No, Cache: Yes
. Cache directory changes: Yes, Permanent: Yes
. Clear aliases: Yes, Unset nat.vars: Yes, Resolve symlinks: Yes
. Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------------------
. Looking up host "portishead.homeip.net"
* (EAccessViolation) EAccessViolation

The option "Do DNS name lookup at proxy end" is = YES, if I change to NO the error is: gethostbyname:unknown error, and that's ok, because only proxy can resolve hostnames, so I think the problem is with connection through proxy server.
Any advices?
kurt

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,801
Location:
Prague, Czechia

Re: WinSCP 3.7.2 Error

Can you try it with version 3.7.1?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,801
Location:
Prague, Czechia

I have tried to fix it, but I have no real proxy to test it. Can you try it for me? Download the maybe-fixed version.

Reply with quote

Advertisement

manuel.flury
Guest

Yep, working again with proxy !

martin wrote:

I have tried to fix it, but I have no real proxy to test it. Can you try it for me? Download the maybe-fixed version.

Hi,

I've tried your fix and it works for me with a proxy.

Without the fix :

. --------------------------------------------------------------------------
. WinSCP Version 3.7.2 (Build 262) (OS 5.1.2600 Service Pack 1)
. Login time: mardi 1 f�vrier 2005 10:19:32
. --------------------------------------------------------------------------
. Session name: linux2610
. Host name: linux2610 (Port: 22)
. User name: manu (Password: Yes, Key file: No)
. Transfer Protocol: SCP
. SSH protocol version: 2; Compression: No
. Agent forwarding: Yes; TIS/CryptoCard: No; KI: Yes; GSSAPI: No
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping type: N, Ping interval: 30 sec; Timeout: 15 sec
. SSH Bugs: -,-,-,-,-,-,-,-
. SFTP Bugs: -,-
. Proxy: HTTP
. HostName: my_http_proxy (Port: 8012); Username: myuserid; Passwd: Yes
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: default, EOL: 0
. Local directory: default, Remote directory: home, Update: No, Cache: Yes
. Cache directory changes: Yes, Permanent: Yes
. Clear aliases: Yes, Unset nat.vars: Yes, Resolve symlinks: Yes
. Alias LS: Yes, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------------------
. Looking up host "linux2610"
* (EAccessViolation) EAccessViolation

With the fix :

. --------------------------------------------------------------------------
. WinSCP Version 3.7.3 (Build 263) (OS 5.1.2600 Service Pack 1)
. Login time: mardi 1 f�vrier 2005 10:24:48
. --------------------------------------------------------------------------
. Session name: linux2610
. Host name: linux2610 (Port: 22)
. User name: manu (Password: Yes, Key file: No)
. Transfer Protocol: SFTP (SCP)
. SSH protocol version: 2; Compression: No
. Agent forwarding: Yes; TIS/CryptoCard: No; KI: Yes; GSSAPI: No
. Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. Ping type: N, Ping interval: 30 sec; Timeout: 15 sec
. SSH Bugs: -,-,-,-,-,-,-,-
. SFTP Bugs: -,-
. Proxy: HTTP
. HostName: my_http_proxy (Port: 8012); Username: myuserid; Passwd: Yes
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: default, EOL: 0
. Local directory: default, Remote directory: home, Update: No, Cache: Yes
. Cache directory changes: Yes, Permanent: Yes
. Clear aliases: Yes, Unset nat.vars: Yes, Resolve symlinks: Yes
. Alias LS: Yes, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------------------
. Looking up host "linux2610"
. Connecting to my_http_proxy port 8012
. Server version: SSH-2.0-OpenSSH_3.9p1
. We claim version: SSH-2.0-WinSCP_release_3.7.3

...etc...


Note that I use the french translation yet and and winscp complains about the presence of the file WinSCP3.fr


Thanks for your support !

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,801
Location:
Prague, Czechia

Re: Yep, working again with proxy !

manuel.flury wrote:

I've tried your fix and it works for me with a proxy.
Thanks for letting me know.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum