DSA key login doesnt work

Advertisement

kaspar
Guest

DSA key login doesnt work

Enclosed a log of what happened.
I generated a DSA key with the puttykeygen program, and then loaded the private key with pagean, and pasted the exact content of the public key to $home/.ssh/authorized_keys and
$home/.ssh2/authorized_keys
I then open winscp (v. 2.2), chose ssh2, enter the servername and and username, and the private key. Then tried connecting, as the log file shows.
What am I doing wrong?

-----------------------------------------------------
WinSCP Version 2.2.0 (Build 122)
Login time: 12. februar 2003 23:08:05
-----------------------------------------------------
Session name: kaspar@*.*.*
Host name: *.*.* (Port: 22)
User name: kaspar (Password: No, Key file: Yes)
SSH protocol version: 2; Compression: No
Agent forwarding: No; TIS/CryptoCard: No; KI: Yes
Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
Ping interval: 0 sec (0 = off); Timeout: 15 sec
SSH Bugs: A,A,A,A,A,A,A,
Proxy: none
Return code variable: Autodetect; Lookup user groups: Yes
Shell: default, EOL: 0
Local directory: default, Remote directory: home, Update: No
Clear aliases: Yes, Unset nat.vars: Yes
Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
--------------------------------------------------------------------------
Looking up host "*.*.*"
Connecting to *.*.*.* port 22
Server version: SSH-1.99-OpenSSH_3.4p1 Debian 1:3.4p1-1
We claim version: SSH-2.0-PuTTY-Local: Jan 26 2003 11:53:20
Using SSH protocol version 2
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange
Host key fingerprint is:
ssh-rsa 1024 *:*:*:*:*:*
Initialised AES-256 client->server encryption
Initialised AES-256 server->client encryption
Reading private key file "E:\key\kaspar3ffgruppe.PPK"
Pageant is running. Requesting keys.
Pageant has 1 SSH2 keys
Trying Pageant key #0
This key matches configured key file
Key refused
Sent password
Access granted
Opened channel for session
Started a shell/command

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,459
Location:
Prague, Czechia

Re: DSA key login doesnt work

Should not it be $home/.ssh/authorized_keys2 instead of $home/.ssh2/authorized_keys?
_________________
Martin Prikryl

Reply with quote

Logiztik
Joined:
Posts:
2
Location:
Denmark

I'm having problems with my dsa key as well, but it's only in winscp mind you. In SecureCRT it works flawlessly.

.. i get the error:
. Reading private key file "C:\MYdir\id_dsa"
. Unable to use this key file (OpenSSH SSH2 private key)
! Unable to use key file "C:\MYdir\id_dsa" (OpenSSH SSH2 private key)


any ideas?

/Logi

Reply with quote

Logiztik
Joined:
Posts:
2
Location:
Denmark

Nevermind I figured it out..
I imported my openssh dsa key into puttygen and saved it to a new file (id_dsa.ppk)
.. changed my connection to use that and viola! problem solved.
/Logi

Reply with quote

Advertisement

You can post new topics in this forum