Batch Problem

Advertisement

Maher
Guest

Batch Problem

Is there any way of setting "option batch on" & "option confirm off" other than using /script, such as thought the .ini file?

I am running the application as a script but I do not wish to save the password in the script file so I call the following command:

winscp.exe user:pass@www.server.com /console /script=file.txt

It works fine but if I get the key exchange screen i.e. "The servers host key is not found...." the application will stall there waiting for user input, i.e. the script file does not execute the batch on & confirm off commands until a session has fully started.

Any ideas?
Thanks
M

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,507
Location:
Prague, Czechia

Re: Batch Problem

You can open the session using "open" command instead of from command line after you issue the "option batch off". But this won't help you anyway as the host key confirmation cannot be supressed for security reasons. You need to confirm the key manually first before using the script files. This problem is already discussed in topic Scripting and Authenticating.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum