Error skipping startup message.

Advertisement

Dork
Guest

Error skipping startup message.

I get this error:
Error skipping startup message. Your shell is probably incompatible with the application (Bash is recommended).

Connection has been unexpectedly closed. Server sent command exit status 0.

I then noticed my user was an FTP user and did not have shell access. This took me a while to figure out and I am reporting this here for users in the future. I may still have issues because I have to wait until shell access is granted before I can test this again.

Reply with quote

Advertisement

Guest

Re: Error skipping startup message.

Dork wrote:

I get this error:
Error skipping startup message. Your shell is probably incompatible with the application (Bash is recommended).

Connection has been unexpectedly closed. Server sent command exit status 0.

I then noticed my user was an FTP user and did not have shell access. This took me a while to figure out and I am reporting this here for users in the future. I may still have issues because I have to wait until shell access is granted before I can test this again.

My problem was that the user password on linux machine expired (I have it set up to expire on 90 days) and the shell didn't start.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: Error skipping startup message.

See documentation for details about "Error skipping startup message" error.
_________________
Martin Prikryl

Reply with quote

Guest

prikryl this answer doesnt help at all since there simply IS NO ERROR IN THE LOGs.
you could as well write "I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason."

thanks......

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason.
_________________
Martin Prikryl

Reply with quote

Guest2
Guest

martin wrote:

I dont have a clue about this error, it just happens randomly on some machines and I'm too freakin lazy to fix it, or even find out the true reason.

Good Job! You did the right thing.

Reply with quote

Guest3
Guest

Error skipping startup message.

For:
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

I found that our problem was the user was using SCP and sudo, and that sshd required a TTY in order to perform this action.

Reply with quote

eddo
Guest

in recived this error when I used:
open scp://user@server -privatekey=C:\myprivatekey.pkk
I resolved in this way
open sftp://user@server -privatekey=C:\myprivatekey.pkk

Reply with quote

Jack.H
Guest

For:
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

I found that our problem was the user was using SCP and sudo, and that sshd required a TTY in order to perform this action.
Thank you! That's exactly the problem I had on Google cloud instance... just need to specify !requiretty in /etc/sudoders

Reply with quote

magesh
Guest

checkpoint winSCP

you probably in the clish mode thats why its not letting you download in the bash.
login in to the GW under user management > users > unlock the screen from above
for example if you use admin account double click the admin there you can change the shell to /bin/bash

Now goto your winscp and download...!!

There we go..!!

Reply with quote

MajorRedbeard
Guest

My problem was that SSH was selected

I got this error after importing sites into a new machine, and after failing to log in several times, I checked the settings. I saw it was set to SSH, rather than SFTP, as intended.

I switched that and it's working as expected now.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,227
Location:
Prague, Czechia

Re: My problem was that SSH was selected

MajorRedbeard wrote:

I got this error after importing sites into a new machine, and after failing to log in several times, I checked the settings. I saw it was set to SSH, rather than SFTP, as intended.
Where did you have "SSH" selected? You cannot switch between "SFTP" and "SSH" in WinSCP. Can you show us a screenshot?

Reply with quote

Noura
Guest

Re: checkpoint winSCP

magesh wrote:

you probably in the clish mode thats why its not letting you download in the bash.
login in to the GW under user management > users > unlock the screen from above
for example if you use admin account double click the admin there you can change the shell to /bin/bash

Now goto your winscp and download...!!

There we go..!!

thanks that works for my checkpoint! ;)

Reply with quote

Advertisement

You can post new topics in this forum