Topic "Keep alive"

Author Message
Guillaume

Guest


Hello

First I wish to thank you for this scp client.

I am using it throught a firewall (thank you for that) but the problem is that the configured timeout is very small (about 5s I guess).

When no data is exchanged for a specified amount of time connection simply stops.

I know you are considering an auto-reconnect or something like that (respawn application?) but you could also add a "keep alive".

Every configurable amount of time you send a low consuming query to the remote host. The problem might be to find which low consuming query is to be used. ls does not apply as there may be hundreds of files.

Maybe you could use something like id or hostname or user configurable command that do not require user input (kind of what you already implemented for the built in shell which is VERY usefull for me).

Hope this helps.
Guillaume
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
WinSCP has keep-alive feature, see "Connection" tab on Login dialog. You must turn on "Advanced options" to see the tab.

However, currently you can setup interval only for whole minutes. I'll change it to seconds in next version.
_________________
Martin Prikryl
Guillaume Lapierre

Guest


Hadn't seen it before !

Make it even better than before if possible (and server timeout is also configurable... Great for I run scripts that take more than 15s to execute Smile)

Thanks again!

Guillaume
kreil
[View user's profile]

Joined: 2005-11-27
Posts: 1
Location: Austria
Fantastic stuff!

I wish there was a similar way to send "advanced keep alives" for PuTTY...

Best regards,

D Kreil.
Andreas

Guest


It seems like "keep alive" only works for the active session. I always get the reconnect dialog when I switch to another opened session if I haven't used it for a while, which indicates that the firewall has killed that connection since no data has been sent.

I usually have several sessions opened to the same host and it's only the active one that seems to survive inactivity, even though keep alive is enabled for all sessions.

Can anyone confirm this behaviour?

Tested in v3.7.6
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Quote:
It seems like "keep alive" only works for the active session. I always get the reconnect dialog when I switch to another opened session if I haven't used it for a while, which indicates that the firewall has killed that connection since no data has been sent.

It's true. I'll try to solve it in the next versions.
_________________
Martin Prikryl
Andreas

Guest


Thanks!

Keep up the good work! It's appreciated!
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License