Topic "Hebrew filename display as gibberish"

Author Message
Tomer

Guest


Hebrew filenames displays like the following line
׳׳ž׳׳׳׳ ׳׳׳׳׳׳׳׳œ׳׳
The linux box is setup with Hebrew support. PuTTY's SSH session to that box shows valid filenames when running ls.
How can I fix this?
Thanks!
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
What is your SSH/SFTP server? OpenSSH?

Also see FAQ.
_________________
Martin Prikryl
Guest




Also seeing this same phenomenon, connecting to OpenSSH server on a Debian 3.1 machine. The files I'm accessing are on a mounted SMB share from a 3rd machine. The third machine is a plain-vanilla XP, and the mount options are
Code:
[color=black][size=12]nodev,noauto,user,iocharset=iso8859-8,codepage=862[/size][/color]
Guest




Screenshot:

<invalid hyperlink removed by admin>
Eyal

Guest


The above-described behavior occurs with 'Server supports UTF-8' set to on. If I set it to off, I don't even see the files - I get an "error with directory listing" message.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
It is most probably that your server report files in non-UTF-8 encoding. Can you mail me a log file at debug 2 log level?
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License