Topic "Error uploading a file while using implicit FTP over TLS"

Author Message
NilsP
[View user's profile]

Joined: 2015-12-10
Posts: 3
Hi all,

I have to use implicit FTP over TLS to upload a file to an external server, but each try ends up in an infinite loop with the error "Timeout detected. (data connection)" and only a zero length file remains.
While using FTP everything works fine. I also tested other clients like FileZilla and FTP Rush which worked well, but - they are not scriptable.
The
Here are some technical informations:
- I have to use a client which is scriptable und runs with Windows.
- I have to use a fixed/public IP address which has been configured by the ISP who is responsible for the FTP server. The IP address was set at WinSCP also.
- Our ISP has mentioned, that all our traffic goes through a proxy even FTP(S). The proxy was set at WinSCP also.

Does anyone experience the same problem like me? If so, you maybe can help me to get WinSCP running?
Feel free to have a look at the log file attached to this post.

Cheers
Nils

Last edited by NilsP on 2015-12-10 14:39; edited 1 time in total
filezilla 20151210.log (6.41 KB) [Download]

Description: Log file with successful transfer

WinSCP 20151210.log (9.9 KB) [Download]

Description: Log file with errors

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Please attach a log file from FileZilla or the other FTP client (a real log file, not the message log from GUI).
NilsP
[View user's profile]

Joined: 2015-12-10
Posts: 3
prikryl wrote:
Please attach a log file from FileZilla or the other FTP client (a real log file, not the message log from GUI).


Thanks for your response. I have just added a log file to my post. Besides this I have tested WinSCP with a local FTPS server and everything worked fine. Maybe the problem is proxy related?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Most probably it's the combination of proxy and TLS.

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
NilsP
[View user's profile]

Joined: 2015-12-10
Posts: 3
You are a magician! Because now it even works like a charm.
The transfer of a 132 bytes test file took about 30 seconds, but I guess this was due to the activated debug mode.

Would you like to receive all the files like described in "Using Debug Build" anyway? If so, I will send you an email with all that stuff attached.

Did you already have scheduled to release a new official version of WinSCP with this bug fixed?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
This bug has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1381
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License