bug in 5.8? permissions after copying from windows to unix

Advertisement

bobmorgan
Joined:
Posts:
6
Location:
Iowa

bug in 5.8? permissions after copying from windows to unix

Version of WinSCP you are using : 5.8 beta
•If the problem started to occur after upgrade, mention the last version of WinSCP which was working for you1) - thought this was ok in 5.1.7
•Version of Microsoft Windows you are running WinSCP on. windows 7
•Transfer protocol (SFTP, FTP, SCP or WebDAV). SCP
•Mention if you use GUI or scripting/automation. If you use GUI, specify interface style you are using (Commander or Explorer). GUI (commander)
•If you experience an error, include full error message. You may use Ctrl+C to copy the message, then paste it (Ctrl+V) to the post. Also check list of common error messages. - no error
•Try to describe precise steps that lead to the problem (where do you click, what keys do you press, what do you see, etc.).

to do some testing I did the following:

changed permissions on a file in unix (through the gui) to read 655
I then dragged that file over to my windows machine via the gui
I deleted the file on the unix system
I then dragged the file from windows to the unix system and it changed the permissions to 640 - is this normal behavior? I guess I would have thought that it would retain its permissions?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,762
Location:
Prague, Czechia

Re: bug in 5.8? permissions after copying from windows to unix

No the permissions are not preserved, as the unix-style permissions cannot be mapped to the Windows-style ACL.

Reply with quote

Advertisement

You can post new topics in this forum