Can't log in through command line. Can login via GUID.

Advertisement

Niftykettles
Guest

Can't log in through command line. Can login via GUID.

Hi.

I can log in via the GUID fine. However when I try running a script containing the password it fails.

Here is the script:

echo open sftp.myuser:4FHe40;r@sftp.myserver.com >> c:\FTP\Script.tmp

The only thing I thought it might be was the ';' in the password but I've tried escaping it with a ^ and % to no avail. I've also tried:

echo open "sftp.myuser:4FHe40;r@sftp.myserver.com" >> c:\FTP\Script.tmp.

I've also tried using a generated session URL and it still fails.

Here is the log file:

. 2016-02-05 09:16:27.063 Initialised HMAC-SHA1 client->server MAC algorithm
. 2016-02-05 09:16:27.063 Initialised AES-256 CBC server->client encryption
. 2016-02-05 09:16:27.063 Initialised HMAC-SHA1 server->client MAC algorithm
! 2016-02-05 09:16:27.079 Using username "sftp.myuser".
. 2016-02-05 09:16:27.079 Prompt (password, "SSH password", <no instructions>, "&Password: ")
. 2016-02-05 09:16:27.079 Using stored password.
. 2016-02-05 09:16:27.095 Sent password
. 2016-02-05 09:16:27.095 Password authentication failed
! 2016-02-05 09:16:27.095 Access denied
. 2016-02-05 09:16:27.095 Prompt (password, "SSH password", <no instructions>, "&Password: ")
. 2016-02-05 09:16:27.095 Disconnected: Unable to authenticate

Any help appreciated

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Can't log in through command line. Can login via GUID.

Enable password logging and show a attach a log file both from GUI and scripting.

Reply with quote

Advertisement

You can post new topics in this forum