WinScp C# MVC not working on server

Advertisement

Igor.Hr
Joined:
Posts:
2
Location:
Hrvatska

WinScp C# MVC not working on server

Web applications written in MVC will not work when it is set to the Web server.

I assume that the problem is not in the firewall or the rights, because when I try to connect from the Web server to destination using WinScp.exe everything works fine.
Localy (on the development workstation) it all works perfectly too.

Debug and Session log attached.

Please help.

Thanks

Br

Igor

p.s. Almost identical post: https://winscp.net/forum/viewtopic.php?t=15846
  • WinScpLogs.7z (3.96 KB, Private file)
Description: DebugLog
SessionLog

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,300
Location:
Prague, Czechia

Re: WinScp C# MVC not working on server

It is most likely about privileges of the web server/web application. Try to increase them.

Reply with quote

Igor.Hr
Joined:
Posts:
2
Location:
Hrvatska

Re: WinScp C# MVC not working on server

I tried everything I could think of ( folder , app pool , site ) and set administrator rights.

I even tried to run WinSCP application process with administrative rights, but it still does not work.

Some other suggestions?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,300
Location:
Prague, Czechia

Re: WinScp C# MVC not working on server

Sorry, I'm not an expert in IIS/webservices.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum