File compare - ot sure if bug report or feature request ! Newbie...

Advertisement

minsik
Joined:
Posts:
2
Location:
Sydney NSW

File compare - ot sure if bug report or feature request ! Newbie...

HI.

Windows 7 32bit and WinSCP 5.7.7 (and also 5.8.2Beta)

I find that syncronised browsing works well between remote sftp and local pc backups (for instance) However find that there are some incosistancies with file compare and syncronised browsing.

File compare works fine when starting with syncronised folder viewing.
if break syncronised folder browsing it is hard hard to get syncronised again.

I thought pressing remote home for instance would re-enable syncronised browsing and then of course file compare. However i find even MUST manually have aligned folders local and remote before activating the syncronised browsing or else it appears on and yet has lost all relationships.

I hope this makes sense?

maybe its a feature request when enable "syncronised browsing" to have both remote and local go to the set folders in the setup?
Then its just a one click button and it would work where as currently it can be button and yet it is not ON really. WinSCP then keeps wanting to create folders locally wherever it might be!!! Waste of time and
frustrating.

Minsik

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,317
Location:
Prague, Czechia

Re: File compare - ot sure if bug report or feature request ! Newbie...

Do I understand right that you want WinSCP to go to predefined (matching pair of) directories when you enable the "synchronized browsing"?

Reply with quote

minsik
Joined:
Posts:
2
Location:
Sydney NSW

Yes that would be the normal assumption.

I select view syncronisation in the site config and the winsftp show the default directories as set in the site config on session start. Then I would like the home button selected and sync browsing is turned on then open the home and other local syncronised directory. In other words a way to return to synconrisation after being unsynced.

At the moment when sync is on for the site and a session is started it works. Then if one of the folders is out of the sync range a warning shows up. However then the only way to get back to sync (even toggling sync on and off doesnt return to the sync folders), is to manually navigate to get the correct sync folders for both remote and local and then turn on sync and its back on. Sometimes i have sync button active but sync is not, then a change of folder can trigger multiple "i am going to create new folders for you every step". Very confusing in my humble opinion.

I do hope this makes sense.


So

If sync is in the site cfg file (yes like this, currently on session open as sync button is active and folders display correctly)
If sync is turned off or disabled because either local or remote is going out of bounds ( yes working correctly and message displays), then sync tuned back on, then directories should become sync again. (NO not working like this currently)
If home button is pressed when sync is turned on then home and remote sync home should display sync folders again. (No not working like this currently )
If sync is off and home button pressed then only remote home should be returned. (yes this works like this now)

Hope clear with this detail.
I have tried 5.8.2b and 5.7.7 release versions.


thanks.

Reply with quote

Advertisement

You can post new topics in this forum