Command line: allow on forwarding

Advertisement

Tomato251
Guest

Command line: allow on forwarding

Hi everbody,

Is it possible to set enable the option "Allow on Forwarding" in a command line?

Thanks for your help.

Ludovic.

Reply with quote

Advertisement

Guest

Hi,

I try this command, but i feel that ingores "/rawsettings TryAgent=1 AgentFwd=1"

WinSCP.exe <user>@<host> /rawsettings TryAgent=1 AgentFwd=1

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,317
Location:
Prague, Czechia

Re: Command line: allow on forwarding

Your syntax is correct.

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

Guest

Hi prikryl,

I use this command

WinSCP.exe j499708%40be16dns%3ASSH%3Aj499708@ssh.bastion.inetpsa.com /rawsettings TryAgent=1 AgentFwd=1 /log="C:\winscp2.log" /loglevel=2
  • winscp2.log (105.47 KB, Private file)
Description: log

Reply with quote

Guest

Hi everybody,

I found a work around, but that need a manual action:

- Select "allow agent forwarding" in Authentification
- click "Set defaults" in Stored sessions

I think with "/rawsettings TryAgent=1 AgentFwd=1" that will easier for end user.

thank you for you help, have a nice day.

Ludovic.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,317
Location:
Prague, Czechia

You are using WinSCP 4.1.8, which is over 7 years old and does not support the the /rawsettings. You urgently need to upgrade.

Reply with quote

Guest

Hi Prikryl,

Yes, you're totaly right...

FYI, I'm in great company, I can't upgrade all WinSCP. I'm going to use a work around by updating the registry in my JAVA program:

reg add "HKCU\Software\Martin Prikryl\WinSCP 2\Sessions\Default%20Settings" /v AgentFwd /t REG_DWORD /d "1" /f

Thanks you for you help.

Ludovic

Reply with quote

Advertisement

You can post new topics in this forum