SSL3 alert write issue after 5.7.7 upgrade

Advertisement

itservices
Joined:
Posts:
3
Location:
Poland, OH

SSL3 alert write issue after 5.7.7 upgrade

Since upgrading to version 5.7.7 we are experiencing the following error message when connecting to an FTP site using TLS/SSL Explicit encryption:

SSL3 alert write: fatal: handshake failure
TLS connect: error in error
Can't establish TLS connection
TLS connect: error in error
Disconnected from server
Connection failed.

Is there a setting that we need to change in the WinSCP client software that will allow us to connect successfully?

Reply with quote

Advertisement

itservices
Joined:
Posts:
3
Location:
Poland, OH

Re: SSL3 alert write issue after 5.7.7 upgrade

I am not sure specifically which version we were previously using however most likely it was a version prior to 5.6.2. Which setting do I need to change on your link to allow SSL3? Maximum TLS/SSL version?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: SSL3 alert write issue after 5.7.7 upgrade

Minimum TLS/SSL version.

Reply with quote

itservices
Joined:
Posts:
3
Location:
Poland, OH

Re: SSL3 alert write issue after 5.7.7 upgrade

Thanks. Unfortunately changing the minimum TLS/SSL version to SSL3 did not resolve the issue. What's weird is that if we use Filezilla to connect we do not have the issue using the same settings.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: SSL3 alert write issue after 5.7.7 upgrade

What cipher does FileZilla use against your server?
Can you try to connect using WinSCP 5.7.6? If it works, please attach a session log file.

Reply with quote

Advertisement

You can post new topics in this forum