Synchronization with exclude filemask still scans directory

Advertisement

MPSinclair
Guest

Synchronization with exclude filemask still scans directory

I am setting up an automated backup for a remote server. I want to have a complete backup first, but then subsequent synchronizations should skip certain directories. It appears though that as long as the directory exists on the local side, it will still scan the directory on the remote server – even with the -filemask="|*/largedirectory/"

If I delete the local version, it will skip scanning it as expected.

Is there any way to keep the local copy but force it to skip scanning the remote folder?

My command looks like:
synchronize local -criteria=Both -filemask="| */largedirectory/"

Cheers!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,542
Location:
Prague, Czechia

Re: Synchronization with exclude filemask still scans directory

Your syntax looks good.

Please attach a full log file showing the problem (using the latest version of WinSCP).

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

MPSinclair
Guest

Please disregard. It was user error. I think what happened is that while I was trying to get the filemask right, I was inadvertently debugging the wrong script. I went back to generate the log when I noticed, and now my filemask is working as expected.

*hangs head in shame*

Thanks so much for the reply and attentiveness though!

Reply with quote

Advertisement

You can post new topics in this forum