Topic "your shell is probably incompatible with the application (bash is recommended)"

Author Message
[View user's profile]

Joined: 2016-04-28
Posts: 1
Location: Bangalore
I tried to download files from SFTP path using private key. I used WinSCP user interface. It works fine. But when I tried with Batch file it shows the error as attached. With the guidance of your forum I have created the batch file. When I run it, command prompt shows that authenticated and then starting the session. But after the it shows an error like "connection has been unexpectedly closed server sent command exit status 1. Error skipping startup message. Your shell is probably incompatible with the application (Bash is recommended).
Please refer the screenshot and suggest.

WinSCP-Error.jpg (64.88 KB) [Download]

Description: (none)

[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26890
Location: Prague, Czechia
Please attach a session log file both from the script and the GUI.

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Martin Prikryl

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License