error in output running WinSCP with script

Advertisement

irrupt
Guest

error in output running WinSCP with script

I think this should say 'exclude' and not 'include'

Active session: [1] FTPUser@192.168.1.15
batch continue
reconnecttime 120
transfer binary
include |*synchronizefolder.txt;C:\Scripts\GAG001-CARREFOUR BEAUSOLEIL D
EC;C:\Scripts\GAG001-CARREFOUR BEAUSOLEIL DEC - Copy;C:\Scripts\GAG001-CARREFOUR
BEAUSOLEIL DEC - Copy (2);C:\Scripts\GAG001-CARREFOUR BEAUSOLEIL DEC - Copy (3)
;
Comparing...

Those files are in the exclude directive in my script for WinSCP

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: error in output running WinSCP with script

Actually, the exclude (and the include) directive is deprecated since 5.0.6.

You should use synchronize -filemask="|*synchronizefolder.txt;C:\Scripts\GAG001-CARREFOUR BEAUSOLEIL D" ...
_________________
Martin Prikryl

Reply with quote

irrupt
Guest

Re: error in output running WinSCP with script

martin wrote:

Actually, the exclude (and the include) directive is deprecated since 5.0.6.

You should use synchronize -filemask="|*synchronizefolder.txt;C:\Scripts\GAG001-CARREFOUR BEAUSOLEIL D" ...

does this work in script mode too?

instead of 'option exclude=file.ext;file2.ext;etc;etc'
use 'option filemask=file.ext;file2.ext;etc;etc' ?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: error in output running WinSCP with script

I do not understand the question.

The synchronize -filemask=... is a scripting command.

There's nothing like option filemask=.

Reply with quote

Advertisement

You can post new topics in this forum