Minor issue with the upgrade notification from 5.8 portable to 5.9

Advertisement

oliverfr
Joined:
Posts:
43

Minor issue with the upgrade notification from 5.8 portable to 5.9

Hello,

This is not a call for help, just a bug report, something apparently didn't work as intended. Maybe you'll be interested in hearing about it.

I have on my (Windows 7) system WinScp 5.8.3 portable, in "c:\Program Files (x86)\WinSCP". At first I had installed the "real" program in there with the installer, but as time passed, I found it more comfortable to use to just unpack in there the latest portable versions when new versions were published.

I discarded the update to 5.8.4.

Then came the notification that 5.9 was available, and I noticed the button proposing to upgrade at once. I thought, "hey, sure", and clicked it. I imagined it would trigger a download of the portable version, since it was written above that auto-updates were for donors only (which I am not.)

That triggered the launch of an updater program to 5.9, but:
- the updater program stalled, telling it couldn't terminate the process (while there were no winscp-anything processes at all, save the current setup program)
- that also killed explorer.exe, which I had to relaunch manually after I clicked "abandon" in the updater program.

No biggie of course, but things clearly didn't work as planned. Thought I might report it.
Have a nice day!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: Minor issue with the upgrade notification from 5.8 portable to 5.9

Thanks for your report. Are you able to reproduce the problem?

Reply with quote

oliverfr
Joined:
Posts:
43

Re: Minor issue with the upgrade notification from 5.8 portable to 5.9

martin wrote:

Thanks for your report. Are you able to reproduce the problem?

Yes.

I downgraded to my previous version (good to be a backup maniac), and, yes, I can reproduce the bug.

Launched version 5.8.3, clicked to check for upgrades, was prompted of an update, clicked Update, that closed WinScp and launched the 5.9 installer (windows asking to allow or not, etc), after which the explorer died, the program didn't respond for like 20 seconds when alt-tabbing to other applications and back to the installer, until at last the attached pic.

In the attached pic, you see the last step, in which I clicked to abandon.
The bottom of the pic ought to have been the windows bar, and instead we see a bit of background.

del.jpg

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: Minor issue with the upgrade notification from 5.8 portable to 5.9

Thanks for the test. What if you downgrade back to 5.8.3 and then run a silent installation of 5.9 like:

WinSCP-5.9-Setup.exe /SILENT /NORESTART /AutomaticUpdate /log=setup.log

Does it have the same problem? If it does, can you post the log file?

Reply with quote

oliverfr
Joined:
Posts:
43

Allright, I did the test with the hard installation (adieu, handy portable versions.)

Two log files. Remember the screenshot I previously posted? That left two routes, ignore, or abandon (or retry, but, well.)

The first log was "abandon" -- and we stayed with WinScp 5.3 portable.
The second log is "ignore" -- that operation ended in winScp5.9 succesfully installed, but the windows Explorer was still dead.
  • setup.log in which I clicked to ignore.log (12.13 KB, Private file)
Description: second log
  • setup.log in which I clicked to abandon.log (4.09 KB, Private file)
Description: first log

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum