Topic "file wont upload"

Author Message
jmac1680
[View user's profile]

Joined: 2016-08-01
Posts: 4
Location: ARIZONA
I am using the most recent version 5.9 of winscp. Using the client interface I can get a file to upload. It has errors but if I change transfer settings, uncheck transfer option of preserve timestamp, the upload goes through just fine. If the file is under 20k, it goes through just fine. The SFTP server on the other side is globalscape.

as part of a batch process, I am using C# code for WinSCP to upload the file, but it will not no matter what I change. I have made the preserve timestamp setting through code as false to match the interface. I have looked at the log files and noticed some differences in settings but don't know what they are to change and try to match. One of those differences I notice in


WinSCP interface log:
Copying 1 files/directories to remote directory "/UAT/FROMHUB/"
. 2016-08-01 11:15:00.422 PrTime: No; PrRO: No; Rght: rw-rw-rw-; PrR: No (No); FnCs: N; RIC: 0100; Resume: S (102400); CalcS: No; Mask: *.*

C# code log:
Copying 1 files/directories to remote directory "/TEST/FROMHUB/"
. 2016-08-01 11:27:44.247 PrTime: No; PrRO: No; Rght: rw-rw-rw-; PrR: Yes (No); FnCs: N; RIC: 0100; Resume: S (102400); CalcS: No; Mask:

the one setting I cant figure out is
PrR: No (No);
Or
PrR: Yes (No);

Anyone know what those are? I get this error when trying to upload with c# code.
* 2016-08-01 11:28:27.229 Error code: 2
* 2016-08-01 11:28:27.229 Error message from server (en): File not found
. 2016-08-01 11:28:27.229 Asking user:
. 2016-08-01 11:28:27.229 Cannot overwrite remote file '/TEST/FROMHUB/ELT_NVTEST1.out'.$$
. 2016-08-01 11:28:27.229
. 2016-08-01 11:28:27.229 Press 'Delete' to delete the file and create new one instead of overwriting it.$$ ("No such file or directory.
. 2016-08-01 11:28:27.229 Error code: 2
. 2016-08-01 11:28:27.229 Error message from server (en): File not found")
< 2016-08-01 11:28:27.229 Script: Cannot overwrite remote file '/TEST/FROMHUB/ELT_NVTEST1.out'.

is the same file in both code and the interface and the same location its being uploaded to as well. I have full log files if needed to show whats going on. Any help would be appreciated. thank you.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Please attach the full log files.
jmac1680
[View user's profile]

Joined: 2016-08-01
Posts: 4
Location: ARIZONA
here is log of winSCP log from interface
WinSCP - Copy.log (12.23 KB) [Download]

Description: (none)

jmac1680
[View user's profile]

Joined: 2016-08-01
Posts: 4
Location: ARIZONA
here is log of winSCP from code.
winscplogCode - Copy.txt (16.08 KB) [Download]

Description: (none)

jmac1680
[View user's profile]

Joined: 2016-08-01
Posts: 4
Location: ARIZONA
you can close this out. turns out the issue was with the permissions on the SFTP server. thank you for the help.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License