5.9.x fails on complex passwords

Advertisement

steveb
Joined:
Posts:
1

5.9.x fails on complex passwords

i'm having trouble with 5.9.1 not passing complex passwords correctly to some servers due to character set issues

i had similar issue with recent putty versions ( around v0.66 ) that was fixed by changing the Remote Character Set for site under

Window -> Translation

in the putty config from UTF-8 to ISO-8859-1

i can't find anyway of doing that with WinSCP 5.9.x so it's impossible to login to affected servers using 5.9.1

5.7.x versions don't suffer from this issue - presumably based on older version of putty which also didn't show the problem

any chance we can get the option change Remote Character Set for sites in WinSCP as per putty config ?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,299
Location:
Prague, Czechia

Re: 5.9.x fails on complex passwords

WinSCP indeed uses UTF-8 for passwords since 5.8, as an SSH specification mandates:
https://winscp.net/tracker/1014

Your should fix your server to adhere to the standards too.

At the moment, we do not plan to add the code-page conversion.

Reply with quote

Advertisement

You can post new topics in this forum