Missing 'Modified Date' after copy.

Advertisement

newuser9876
Guest

Missing 'Modified Date' after copy.

When I copy a file from win7 to windows 2012R2 via sshd (on 2012R2) the 'Modified Date' is missing in the file. This causes that file to NOT SHOW up in the file list, however the file does get copied to the destination dir.

I'm using the latest WinSCP 5.9.2 build 6958. What can be possibly wrong with my configuration? It seems highly unlikely that everyone would have this problem.

THanks

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Re: Missing 'Modified Date' after copy.

Thanks for your report.
What does it mean "copy a file ... via sshd"?
What does it mean "the 'Modified Date' is missing in the file"?
Maybe some screenshots would help us understand the problem better.

Reply with quote

newuser9876
Guest

So the setup up is this:

1) Windows 7 Running WinSCP client.

2) Windows 2012R2 running SSHD (Server).

3) Connecting with WinSCP to 2012R2 with SFTP.

4) Copy of file from Window 7, Copied file on 2012R2 is missing Modified Date, see pic attached.

5) Copy of file from 2012R2 to Windows 7, no problem.

Hope this helps to troubleshoot.

Regards

Description: This is how the file looks after it is copied.

FileWithNoModifiedDate.png

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

OK, do you have the same problem with other SFTP clients? PSFTP? FileZilla?

Reply with quote

Advertisement

chanh
Joined:
Posts:
7
Location:
United States

Blank Modified Date since after version 5.5.6

I know this is an old thread but I spent many days on this issue and finally, I am able to narrow down the issue.

Please see attached file that shows the same file with the same INI file but switching between various version between 5.5.6 to 5.13.3 where it shows the Modified Date is blank for all version except for version 5.5.6

What do you think might be the cause of this problem?

Thanks

WinSCP_blank_modified_date_after_556.PNG

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Re: Blank Modified Date since after version 5.5.6

chanh wrote:

I know this is an old thread but I spent many days on this issue and finally, I am able to narrow down the issue.

Please see attached file that shows the same file with the same INI file but switching between various version between 5.5.6 to 5.13.3 where it shows the Modified Date is blank for all version except for version 5.5.6
Thanks for your report.
Can you post log files showing a directory listing from both WinSCP 5.5.6 and WinSCP 5.13.3?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Re: Dir Listing 5.5.6 vs 5.13.3

Thanks for your response. But I need full log files. Not screenshots of piece of them.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Thanks for the logs.

This issue has been added to the tracker:
https://winscp.net/tracker/1672

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum