Topic "Shell sudo -s has no effect"

Author Message
Guest




This maybe a frequently asked question, but I do checked the FAQ and searched a lot.

What I did is:
1. Add "myname ALL = NOPASSWD: ALL" into /etc/sudoers
2. Advanced site settings -> Shell -> Shell, input sudo -s

After this, I am still telled if edit files with rwxr-xr-x

Permission denied.
Error code: 3
Error message from server: Permission denied

Could anyone help me with the problem?
Any help will be highly appreciated.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
The Shell option is for the SCP protocol. While it seems that you are using the SFTP protocol. So use the SFTP server option.

See https://winscp.net/eng/docs/faq_su
Guest




Martin, Thanks a lot for your reply.
Actually, I have tried both SFTP and Shell.

If set SFTP server to "sudo /bin/sftp-server", the login fail, it says

Sever sent command exit status 1
Cannot initialize SFTP protocol. Is the host running an SFTP server?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
And does the /bin/sftp-server exists?
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License