Task Scheduler error, but when run manually no error

Advertisement

mcruz
Joined:
Posts:
1
Location:
Puerto Rico

Task Scheduler error, but when run manually no error

Hi to all.

I have created the following batch:

{
option batch abort
option confirm off

open ftp://(USER):(PASSWORD)@ftp.com/folder/inbox/ -explicittls
put "Y:\*"

close
exit
}

When i run it manually (double click to it) it will run with no problems. But if i put it in a task scheduler to run it give me the following error.



C:\Program Files (x86)\WinSCP>winscp.com /script=SyncToRemoteScript.txt
batch abort
reconnecttime 120
confirm off
Connecting to ftp.com ...
TLS connection established. Waiting for welcome message...
Connected
Starting the session...
Session started.
Active session: [1] ***@ftp.com
No file matching '*' found. (System Error. Code: 3.
The system cannot find the path specified)
Session '***@ftp.com' closed.
No session.


but if i run it manually


C:\Program Files (x86)\WinSCP>winscp.com /script=SyncToRemoteScript.txt
batch abort
reconnecttime 120
confirm off
Connecting to ftp.com ...
TLS connection established. Waiting for welcome message...
Connected
Starting the session...
Session started.
Active session: [1] ***@ftp.com
PR7_MN32_10242016_122526_ | 328 B | 1.4 KB/s | binary | 100%
Session '***@ftp.com' closed.
No session.

Would you help to solve this,

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,226
Location:
Prague, Czechia

Re: Task Scheduler error, but when run manually no error

I assume the problem is that the account that drives your task scheduler task does not see the Y: drive or does not have a network access at all. Try doing dir Y:\ in your task.

Reply with quote

Advertisement

You can post new topics in this forum