WinSCP hanging minimized win2k

Advertisement

muffinresearch
Guest

WinSCP hanging minimized win2k

I'm having a strange problem where when I start up winSCP I select a server and sinscp connect but then the application hangs minimized.

I fixed it once by full ininstallation and reinstallation and at that point I change to .ini config. However it's come back. I will try and investigate further to see if I can find why it's happening.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: WinSCP hanging minimized win2k

Would it help if you remove your configuration (registry and INI file)? Backup it first. If it helps, please send the backed up configuration to me.
_________________
Martin Prikryl

Reply with quote

galen
Guest

Me too

I was using WINSCP with no problems for a month.
Now I have the same problem again and again.
When I uninstall and reinstall it works again... but the problem returns randomly.
Is there a solution?

Saludos
Ral

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Re: Me too

galen wrote:

I was using WINSCP with no problems for a month.
Now I have the same problem again and again.
When I uninstall and reinstall it works again... but the problem returns randomly.
Is there a solution?
Please send me an email, so I can send you back a debug version.
_________________
Martin Prikryl

Reply with quote

Advertisement

setia
Guest

Even I had the same problem today and we some luck got it resolved. Here is what I did...
0. Took backup of HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2
1. Opened WinScp Login page.
2. Clicked on Tools...
3. From the floating menu, Clean up...
4. Check everything except "Stored Sessions". I kept in unchecked since I had many stored sessions and didn't want to lose the list and I was sure the problem could not be because of stored sessions since all the WinSCP sessions ( to any host ) were hanging for me.
5. click Ok

No message came. It is sort of a strange since I was expecting something say "Cleanup over..". Anyway, I closed WinScp and reopened and now I was able to connect to all servers without any issue at all.
So, in nutshell, Tools...Cleanup....option came to rescue.

I observed that after cleanup, Configuration folder was gone. Later when I restarted WinSCP it came back. So, the intelligent software rebuilded the configuration folder in the registry.

Setia

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,802
Location:
Prague, Czechia

Thanks. If it ever happens again, please contact me so I can send you a debug version to trace the problem.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum