Topic "WinSCP2 uses scp1 even when "Use scp2 with scp1 compat" checked"

Author Message
sgsmith1
[View user's profile]

Joined: 2003-03-18
Posts: 1
I have only scp2 available on the UNIX side. I have "Use scp2 with scp1 compat" checked in the SHELL tab, but the log still shows that scp1 is not found. I have tried this with the ssh preference set to 1, 2, and 2 only. I have also created a file on the UNIX side .ssh/environment that has PATH=/usr/local/bin:$PATH. I have tried all the combinations, with and without this environment file. I still get this error message:

WinSCP: this is begin-of-file
Sending NULL.
scp: warning: Executing scp1 compatibility.
scp: FATAL: Executing ssh1 in compatibility mode failed (Check that scp1 is in your PATH).
WinSCP: this is end-of-file:255

I am using a proxy on port 1080. I have tried it with both packet forwarding on and off.

Any ideas?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25015
Location: Prague, Czechia
WinSCP always needs scp1.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License