Topic "WinSCP Keeps asking for FTP Password when it gets disconnected"

Author Message
Jimmycan
[View user's profile]
Donor
Joined: 2017-01-04
Posts: 2
Location: UK
I am using WinSCP version 5.9.3 Build 7136 in ftp mode to copy files from a Windows 2012 R2 Server to a remote NAS Unit.

I am using the Commander Interface with the option "Keep remote Directory up to date". I have saved the options to connect to the remote Unit using a Synology DS414.

When I connect it begins to upload files and I leave it to upload. However when I go back to it perhaps 1 hour later it is sitting asking for a password. I type the password in again and it continues to copy.

I have selected the option to remember the password for this session. It seems to happen if the connection is broken and cannot automatically reconnect with the remembered password.

How can I fix the problem?
Advertisements
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
Thanks for your report. I'll look at this problem and I'll contact you soon.
Jimmycan
[View user's profile]
Donor
Joined: 2017-01-04
Posts: 2
Location: UK
Jimmycan wrote:
I am using WinSCP version 5.9.3 Build 7136 in ftp mode to copy files from a Windows 2012 R2 Server to a remote NAS Unit.

I am using the Commander Interface with the option "Keep remote Directory up to date". I have saved the options to connect to the remote Unit using a Synology DS414.

When I connect it begins to upload files and I leave it to upload. However when I go back to it perhaps 1 hour later it is sitting asking for a password. I type the password in again and it continues to copy.

I have selected the option to remember the password for this session. It seems to happen if the connection is broken and cannot automatically reconnect with the remembered password.

How can I fix the problem?


Thanks
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
This bug has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1498

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.
Guest




Hi I tried that but it still happens. It's seems to happen more on slower connections.

Is there any way post log files which would allow more information to be gathered?
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
I have sent you an email with a debug version of WinSCP.
_________________
Martin Prikryl
Tython

Guest


Im having the excact same problem. Im using a forticlient vpn which gives me a unique ip adress. As the op Im also trying to use the synchronization feature. Im trying to replicate the folders from the local machine onto a remote server. Whenever I reconnect from the vpn connection it tells me to manually type in the ftp password even tho Ive enabled the possibility to automate this.

Anything im missing here? Im using Winscp 5.11.2, build 7781.
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27059
Location: Prague, Czechia
Tython wrote:
Im having the excact same problem. Im using a forticlient vpn which gives me a unique ip adress. As the op Im also trying to use the synchronization feature. Im trying to replicate the folders from the local machine onto a remote server. Whenever I reconnect from the vpn connection it tells me to manually type in the ftp password even tho Ive enabled the possibility to automate this.

Please start a new topic for your problem. There, describe how did you "enabled the possibility to automate this" and include a full log file.
Advertisements

You can post new topics in this forum

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License