Topic "WinSCP does not start after wrong putty path"

Author Message
J-typ
[View user's profile]

Joined: 2017-01-09
Posts: 2
Hello!

I installed WinSCP 5.9.3 correctly (Windows 8.1). After that I changed the path to putty and added an "-X" (using Preferences->Application) but I did a mistake; it seems that I deleted the "exe" of "putty.exe" and, perhaps, also went wrong with quotation marks.

However, if I now try to start WinSCP the following error message (in German - I translated it) occurs with the button "OK" and "Help". Independent of the button I press WinSCP does not start. The program only closes. So, I am not able to correct the wrong path to putty. This is the error message:

-------------
Error - WinSCP
invalid command '"C:\Program Files\putty\putty.-X'.
-------------

In addition, uninstalling WinSCP does not help! That is weird! Even during the uninstall routine the above error message occurs. It seems that WinSCP is not fully uninstalled but all files and directories are deleted as far as I can see. Same error message occurs during the install routine after uninstalling. That's why I guess it's not uninstalled fully. I am still not able to open the program or uninstall and re-install it in a clean version.

Thanks for help!
Regards!
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26711
Location: Prague, Czechia
Thanks for your report.

This issue has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1499

To reset the PuTTY path, run WinSCP once like this:

winscp.exe /rawconfig Interface\PuttyPath=
J-typ
[View user's profile]

Joined: 2017-01-09
Posts: 2
Thank you very much, Martin!
After setting the putty path correctly it works perfectly fine!
Advertisements

You can post new topics in this forum

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License