Internal editor switches OS kbd language after many non letter/numerical key press

Advertisement

ron14
Guest

Internal editor switches OS kbd language after many non letter/numerical key press

OS: XP SP3, English and Hebrew settings.
WinSCP: 5.9.3 (Build 7136)
Internal editor encoding set to UTF-8.

How to reproduce?
Click New File -> enter what ever file name desired, in whatever language -> Editor opens. XP kbd language indication is set to English now. I don't know if that is always the case. In any case, I changed the kbd settings to Hebrew. I still haven't written anything to the file. Now pressing the dedicated End keyboard key changes the OS keyboard setting back to English. Which is not what is expected, and not the way other applications behave. Note that I haven't written anything to the file just to ease reproduction of the bug. A similar, confusing, inconvenient behavior is seen for the Home key, and probably more keys.

I assume the problem will persist with any right to left (RTL) language, that is also with Arabic and Persian. I don't know what happens with other multi language installations.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: Internal editor switches OS kbd language after many non letter/numerical key press

Thanks for your report.
Do you have the same problem or newer versions of Windows (7 or 10)?

Reply with quote

Advertisement

You can post new topics in this forum