Topic "Problem with sync"

Author Message
seanb724
[View user's profile]

Joined: 2005-09-19
Posts: 3
I am trying to set up an auto synchronize from a FreeBSD server on the Net to my windows box at home. The direction is "local" such that the local dir becomes a mirror of whats online. I see the problem whether I'm doing this via automated scripts or manually attempting it.

It works great for everything excep maildir folders. At 1st I thought the the windows box was showing timestamps with second precesion whereas the BSD box was just showing minute precision, but that does not now appear to be the case. I tried the sync using file size instead of modification time.

My latest theory is that the mail messages in maildir have a ":" in them on the BSD side, but have "%3A" on the Windows side. So these files always show up as different, and are deleted from the windows box and then downloaded again from the BSD box.

Does this sound plausible, and is there a fix?

thanks,
Sean
Advertisements
seanb724
[View user's profile]

Joined: 2005-09-19
Posts: 3
p.s. I tried deselecting "replace invalid characters with \" but that just made the windows file name not match from the ":" on...
seanb724
[View user's profile]

Joined: 2005-09-19
Posts: 3
p.p.s. I'm using 3.7.6... I searched through the forums and found one reference to this, stating that after version 3.2, invalid characters could be substituted. But I'm not so sure it's working. I see no other differences in the file names other than the time stamp showing seconds on windows and minutes on unix (but that seems to be ok on all other files!) and the colon issue... I definitely see the %3A on the files once they are downloaded to the windows server, but then those same files are always deleted and re-downloaded when I synch.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
seanb724 wrote:
My latest theory is that the mail messages in maildir have a ":" in them on the BSD side, but have "%3A" on the Windows side. So these files always show up as different, and are deleted from the windows box and then downloaded again from the BSD box.

Does this sound plausible, and is there a fix?

There's no fix. WinSCP currently cannot handle such files correctly for synchronisation.
_________________
Martin Prikryl
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
seanb724 wrote:
p.s. I tried deselecting "replace invalid characters with \" but that just made the windows file name not match from the ":" on...

I do not understand this one.
_________________
Martin Prikryl
Guest




prikryl wrote:
seanb724 wrote:
My latest theory is that the mail messages in maildir have a ":" in them on the BSD side, but have "%3A" on the Windows side. So these files always show up as different, and are deleted from the windows box and then downloaded again from the BSD box.

Does this sound plausible, and is there a fix?

There's no fix. WinSCP currently cannot handle such files correctly for synchronisation.


Is there a planned fix for this? Smile

If not, that's fine. I have it synching everything except maildir now, and I can just gzip those dirs and sync those files, perhaps...
Guest




prikryl wrote:
seanb724 wrote:
p.s. I tried deselecting "replace invalid characters with \" but that just made the windows file name not match from the ":" on...

I do not understand this one.


If you tell winscp to not do the replacement of invalid characeters, it just stops the file name at the 1st invalid character.

/Sean
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Anonymous wrote:
Is there a planned fix for this? Smile

Added to TODO list Smile
_________________
Martin Prikryl
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Quote:
If you tell winscp to not do the replacement of invalid characeters, it just stops the file name at the 1st invalid character.

Can you tell exact name (including path) for which this occur?
_________________
Martin Prikryl
Guest




prikryl wrote:
Quote:
If you tell winscp to not do the replacement of invalid characeters, it just stops the file name at the 1st invalid character.

Can you tell exact name (including path) for which this occur?



For a maildir name such as:

1127243058.60634_1.east.2sparrows.org:2,ST

It is copied from unix to windows via winscp as:

1127243058.60634_1.east.2sparrows.org

If you have "do not replace invalid characters" checked in the synchronize settings. If you have it set to replace, the file is xfered as:

1127243058.60634_1.east.2sparrows.org%3A2,ST


/Sean
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Quote:
For a maildir name such as:

1127243058.60634_1.east.2sparrows.org:2,ST

It does not do this for me. Instead error massage is shown stating that such file cannot be created. Can you post the script file that you use. Also do you use SFTP or SCP?
_________________
Martin Prikryl
Guest




prikryl wrote:
Quote:
For a maildir name such as:

1127243058.60634_1.east.2sparrows.org:2,ST

It does not do this for me. Instead error massage is shown stating that such file cannot be created. Can you post the script file that you use. Also do you use SFTP or SCP?



I'm using SCP, though this appears to happen with both SFTP and SCP.

Here's the file:

option batch on
open xxx@yyy.com
option exclude "maildir; *mrtg*; *spamass*"
option synchdelete on
synchronize local d:\2sparrows-backup /home
close
exit

It's in the saved profile for xxx@yyy.com where I have it set to not replace special chars (or to replace them).

BTW, I have this working by zipping up maildir, where the ":" shows up in the file names, so it's not a huge deal. It does mean that the zipped file get's synch'd every night.

/Sean
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
It seems that at least WinXP (Win2K seems not) does not refuse creation of file with single comma in the middle. Instead it ignores filename part before (and including) the comma. If you have filename with 2 commas or other dissalowed character, error occurs.
_________________
Martin Prikryl
Guest




Any updates on this matter? I still do have the problem that ":" is renamed to "%3A" on windows and thus the synchronize option is not working.

Greets
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
This is not solved yet.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License