Topic "WinSCP Works on one FTP Site but not another"

Author Message
MikeJKemp
[View user's profile]

Joined: 2017-02-09
Posts: 4
Help! I am using WinSCP ver 5.9.3 (build 7136) on a Windows 7 Prof. machine having just moved across from my old Win XP SP3 machine where WinSCP worked wonderfully.

I have two FTP sites that I currently wish to connect to, one connects beautifully with just the standard info entered on the WinSCP panel. The other constantly reports 'Connection Failed' - 'Disconnected from Server': it also has reported 'Timeout detected' - 'Control Connection'.
I have extended the timeout settings with no success.
I am attaching two log files, one the successful site - head includes novus - the other is the unsuccessful site. I have blanked out the passwords that appear in the log files.
The Win XP setup connected perfectly with the same FTP site that is now giving me grief.

I backed up the WinSCP settings on Win XP and restored them to the Win 7 setup so I am sure that I have the same URL and password settings.

I really would welcome some suggestions how to fix this problem: thanks in advance.
TXC_user@ftp.emeaseapp.swpti.co.uk.log (33.5 KB) Private file

Description: (none)

novusfx_doc@ftp.trapezegroup.co.uk.log (22 KB) Private file

Description: (none)

Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25946
Location: Prague, Czechia
Do you know, what version of WinSCP were you using on the Windows XP machine?

Can you connect with any other FTP client?

The server seems to choke on the CLNT command. Versions of WinSCP prior to the 5.8.1 would probably not send the CLNT command to the server. Can you try an older version of WinSCP? (not that I recommend you using them, it's just to testing purposes)
MikeJKemp
[View user's profile]

Joined: 2017-02-09
Posts: 4
Thank you for your response: the version of WinSCP that connects well is 5.7.7.
Can I change the config of the current version to work around the problem?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25946
Location: Prague, Czechia
No, the latest version of WinSCP sends the CLNT command to all servers that announce a support for the command.
What the server does:

Quote:
> 2017-02-09 16:34:18.738 FEAT
< 2017-02-09 16:34:19.159 211-Extension supported
< 2017-02-09 16:34:19.752 CLNT
...
MikeJKemp
[View user's profile]

Joined: 2017-02-09
Posts: 4
Thanks for your help: reverting to ver.5.7.7 has solved the problem although I note that 'CNT' appears in the log file (attached). Although my use of WinSCP is limited, generally once a month, it has been an invaluable tool.
I found it interesting that attempting to connect to my 'problem' site directly via Firefox also met with a problem.
TXC_user@ftp.emeaseapp.swpti.co.uk.log (7.16 KB) Private file

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25946
Location: Prague, Czechia
You should get them to upgrade their FTP server. The bug might have been fixed already.
MikeJKemp
[View user's profile]

Joined: 2017-02-09
Posts: 4
Sadly, that's beyond my control or influence; though I might mention it to the guy that feeds the files into it. Many thanks for your help.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License