Topic ""+" replaced by " " on URL when running from CLI"

Author Message
AVB

Guest


Hello,

First, I'd like to thank you this great tools I use everyday !

When WinSCP is launched from WinSCP.com or WinSCP.exe CLI, if a "+" is contained in the full URL (especially on username), it is replaced by a " " and authentication fails:

Here is an exemple with a Cygwin SSH Server (FYI: it's in french):
Quote:
C:\Program Files (x86)\WinSCP>winscp.com sftp://DOMAIN+USER:PASSWORD@SERVER.FQDN
Ouvrir une session en utilisant un paramètre de la ligne de commande est déprécié. Utilisez la commande 'open' à la place.
Recherche de l'hôte... (Searching for host)
Connexion à l'hôte... (Connecting to host)
Authentification... (Authentication)
Utilisation du nom d'utilisateur "DOMAIN USER". (Using the Username DOMAIN USER -Without '+' !-)
Authentification avec le mot de passe pré-entré. (Authentication with given password)
Accès refusé. (Access Denied)
Déconnexion inattendue Résultat de la commande exit sur le serveur 0 (Unexpected disconnection...)
Log d'authentification (voir le log de session pour les détails) (See log for more details)
Utilisation du nom d'utilisateur "DOMAIN USER". (Using username "DOMAIN USER")
Accès refusé. (Access Denied)

Erreur d'authentification (Authentication failure)


With WinSCP.exe, exact same issue.

I tried to escape + and various other workaround but without success.

WinSCP Version: 5.9.4 (Tried with recent but older version: same issue to)
OS: Windows 10 x64 Enterprise
-u argument used with cmd.exe doesn't change anything.

Hope this helps !

Regards,
AVB
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 27082
Location: Prague, Czechia
Please read documentation:
https://winscp.net/eng/docs/session_url#special

If that does not help, come back.
AVB

Guest


Ok thanks !
Advertisements

You can post new topics in this forum

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License