Setting "session timeout?"

Advertisement

cara
Joined:
Posts:
8

Setting "session timeout?"

Our vendor just moved us to a new SFTP server, and I'm now having intermittent issues with downloads that had been working.

I'm attaching the powershell script where I thought that adding
$session.Timeout = new-timespan -minutes 5
would do the trick, but apparently I'm guessing wrong!

I'm also attaching the debug log file, showing a 15 second timeout, I think.

What's the correct way for me to, as the vendor recommended, "...increase the time out in winscp..." ?

thanks
  • PowerShell_Script.txt (5.4 KB, Private file)
  • 20170316-1207_SessionDebug.log (121.55 KB, Private file)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,599
Location:
Prague, Czechia

Re: Setting "session timeout?"

I cannot see any timeout in the log.

Anyway, you probably want this:

$sessionOptions = New-Object WinSCP.SessionOptions -Property @{
    ...
    Timeout = new-timespan -minutes 5
}
(You actually have it already in the code, just commented-out).

Reply with quote

cara
Joined:
Posts:
8

Thanks again, Martin.

I think I had that line commented out because I wasn't sure it was the right way to do it -- but I didn't realize I had NO method in use, so I appreciate the pointer!

I'm trying again with tonight's scheduled run.

Reply with quote

Advertisement

You can post new topics in this forum