Topic "Error 0xc0000006 on Windows 10"

Author Message
wdonovan
[View user's profile]

Joined: 2017-03-20
Posts: 3
Location: New York
The following error occurs when starting WinScp.exe.
The application was unable to start correctly (0xc0000006).

Version 5.9.4 Build 7333
Windows 10 64-bit
Protocol: SFTP

This has worked in the past on this PC. However it no longer does.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
wdonovan
[View user's profile]

Joined: 2017-03-20
Posts: 3
Location: New York
I ran the debug version on the affected PC but no error occurred. It worked as expected. The original version (non-debug) still produces the error. Debug log attached. I noticed the debug version is 5.10 but the original version we use is 5.9. Could that be the issue?
WinSCP8390trace.zip (999.08 KB) [Download]

Description: (none)

martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
I've sent you a development build for testing.
wdonovan
[View user's profile]

Joined: 2017-03-20
Posts: 3
Location: New York
The new development build seems to work fine.

Thanks!
bbrennetot

Guest


Hello,
I have the same problem for about 10 days but in a different context. The winscp.exe (5.1.7.3446) program was placed on a network share and is used on the command line to access sftp folders.
For a few days, as soon as we launch winscp.exe from some PCs under windows 7, we get the error message "The application was unable to start correctly (0xc0000006).". Yet we have not changed anything for several months.
However, if we copy the same file to the local machine, it works perfectly. We tried to uninstall the latest Windows updates, disable the Kaspersky antivirus, move the program on another server, download the latest version of winscp (5.9.4.7333) but the problem persists.
Moreover, I can't get logs, since all the options passed as parameters of the launch of the exe are not taken into account, the error message is displayed before.
Could you help me, please?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
wdonovan wrote:
The new development build seems to work fine.

Thanks for your feedback. Though it's actually strange.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
bbrennetot wrote:
Hello,
I have the same problem for about 10 days but in a different context. The winscp.exe (5.1.7.3446) program was placed on a network share and is used on the command line to access sftp folders.
For a few days, as soon as we launch winscp.exe from some PCs under windows 7, we get the error message "The application was unable to start correctly (0xc0000006).". Yet we have not changed anything for several months.
However, if we copy the same file to the local machine, it works perfectly. We tried to uninstall the latest Windows updates, disable the Kaspersky antivirus, move the program on another server, download the latest version of winscp (5.9.4.7333) but the problem persists.
Moreover, I can't get logs, since all the options passed as parameters of the launch of the exe are not taken into account, the error message is displayed before.
Could you help me, please?

Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
bbrennetot
[View user's profile]

Joined: 2017-03-30
Posts: 2
Location: Paris
I created an account with the same username: bbrennetot
I sent you an e-mail.
Thank you in advance for your help
bbrennetot
[View user's profile]

Joined: 2017-03-30
Posts: 2
Location: Paris
The WinSCP1F5Ctrace.log file does not generate on the network share while I have the right to write. I also added a WINSCPTRACE environment variable to my local disk c:\ but no result.
The error message appears as soon as I start Winscp.exe or Winscp.com.

But everything works fine when I copy the folder that contains the Winscp.exe on my local drive. Winscp starts and the trace file is generated.

I don't understand where this problem comes from.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
Probably some local policy prevents some operation that WinSCP needs to startup correctly.

You can try to debug the startup using Process Monitor:
https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License