Topic "Loading the WinSCP.net to GAC"

Author Message
whess

Guest


I'm working on using WinSCP to automate the task of sending files via SFTP.
When in Visual Studio I can setup a process to run and send the file with no problem.
I can also run it from the command prompt and the file transfers.
When I deploy the package though the process errors out.
Message I get back is that was expecting a 0 and received a 1.
I'm thinking it is because I don't have the WinSCP.net loaded to the GAC that is mentioned in the forums.
Problem is how to install the .net assembly to the GAC.
All the documentation I've seen says I can use Visual Studio 2012 to load it but our servers only have the 2012 Shell installed and not the full version.
I have also tried the gacutil and it errored out for the same reason saying I didn't have the full version of Visual Studio.

Any other way to get the .net assembly loaded to the GAC or what could be the problem why I'm getting the error.
Thanks in Advance.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26572
Location: Prague, Czechia
This is not really WinSCP question.

Try asking on Stack Overflow or similar site.

Please post a link here, if you do.
Advertisements

You can post new topics in this forum






Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License