Session password issue

Advertisement

dan
Guest

Session password issue

Hello,
If I use putty or psftp I can sucessfully login to the server, if I use winscp it keeps asking for session password. I have already entered the user amd pw in the session dialog, what am I missing?

Thanks
Dan

Reply with quote

Advertisement

d_original
Guest

Session password issues

Hi,


i have same problems, would be glad if some had a solution to this issues?
PS:before i got this problem i entered the login details and save the session now when i try to login it keeps asking for the session password which i entered same as the login password.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,069
Location:
Prague, Czechia

Re: Session password issues

First, check the server's log to see why it denies you to login.
_________________
Martin Prikryl

Reply with quote

Rocknolds
Guest

Re: Session password issues

martin wrote:

First, check the server's log to see why it denies you to login.

How and where will I get to see the logs that you are talking? I can connect using SSH (Putty) to my Fedora4 Linux server.

Thanks a lot.

Reply with quote

rctablada@...
Guest

Re: Session password issues

I hope this will help. Thanks

. 2005-10-18 21:31:11.549 --------------------------------------------------------------------------
. 2005-10-18 21:31:11.549 WinSCP Version 3.7.6 (Build 306) (OS 5.1.2600 Service Pack 2)
. 2005-10-18 21:31:11.549 Login time: Tuesday, October 18, 2005 9:31:11 PM
. 2005-10-18 21:31:11.549 --------------------------------------------------------------------------
. 2005-10-18 21:31:11.549 Session name: session
. 2005-10-18 21:31:11.549 Host name: 172.16.68.10 (Port: 22)
. 2005-10-18 21:31:11.549 User name: rtablada (Password: Yes, Key file: No)
. 2005-10-18 21:31:11.549 Transfer Protocol: SFTP (SCP)
. 2005-10-18 21:31:11.549 SSH protocol version: 2; Compression: No
. 2005-10-18 21:31:11.549 Agent forwarding: No; TIS/CryptoCard: No; KI: Yes; GSSAPI: No
. 2005-10-18 21:31:11.549 Ciphers: aes,blowfish,3des,WARN,des; Ssh2DES: No
. 2005-10-18 21:31:11.549 Ping type: -, Ping interval: 30 sec; Timeout: 15 sec
. 2005-10-18 21:31:11.549 SSH Bugs: -,-,-,-,-,-,-,-
. 2005-10-18 21:31:11.549 SFTP Bugs: -,-,-
. 2005-10-18 21:31:11.549 Proxy: none
. 2005-10-18 21:31:11.549 Return code variable: Autodetect; Lookup user groups: Yes
. 2005-10-18 21:31:11.549 Shell: default, EOL: 0
. 2005-10-18 21:31:11.549 Local directory: default, Remote directory: home, Update: No, Cache: Yes
. 2005-10-18 21:31:11.549 Cache directory changes: Yes, Permanent: Yes
. 2005-10-18 21:31:11.549 Clear aliases: Yes, Unset nat.vars: Yes, Resolve symlinks: Yes
. 2005-10-18 21:31:11.549 Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. 2005-10-18 21:31:11.549 --------------------------------------------------------------------------
. 2005-10-18 21:31:11.549 Looking up host "172.16.68.10"
. 2005-10-18 21:31:11.549 Connecting to 172.16.68.10 port 22
. 2005-10-18 21:31:11.564 Server version: SSH-2.0-OpenSSH_4.0
. 2005-10-18 21:31:11.564 We claim version: SSH-2.0-WinSCP_release_3.7.6
. 2005-10-18 21:31:11.564 Using SSH protocol version 2
. 2005-10-18 21:31:11.564 Doing Diffie-Hellman group exchange
. 2005-10-18 21:31:11.611 Doing Diffie-Hellman key exchange
. 2005-10-18 21:31:12.002 Host key fingerprint is:
. 2005-10-18 21:31:12.002 ssh-rsa 1024 53:a7:95:6e:d3:77:46:9e:5b:6b:17:a8:3d:a2:2a:f4
. 2005-10-18 21:31:12.002 Initialised AES-256 client->server encryption
. 2005-10-18 21:31:12.002 Initialised HMAC-SHA1 client->server MAC algorithm
. 2005-10-18 21:31:12.002 Initialised AES-256 server->client encryption
. 2005-10-18 21:31:12.002 Initialised HMAC-SHA1 server->client MAC algorithm
! 2005-10-18 21:31:12.033 Using username "rtablada".
. 2005-10-18 21:31:12.033 Session password prompt (rtablada@172.16.68.10's password: )
. 2005-10-18 21:31:12.033 Using stored password.
. 2005-10-18 21:31:12.033 Sent password
! 2005-10-18 21:31:14.690 Access denied
. 2005-10-18 21:31:14.690 Access denied
. 2005-10-18 21:31:14.690 Session password prompt (rtablada@172.16.68.10's password: )
. 2005-10-18 21:31:14.690 Asking user for password.
. 2005-10-18 21:31:16.002 Unable to authenticate
. 2005-10-18 21:31:16.002 Attempt to close connection due to fatal exception:
* 2005-10-18 21:31:16.002 Unable to authenticate
. 2005-10-18 21:31:16.002 Closing connection.
* 2005-10-18 21:31:16.002 (ESshFatal) Authentication failed.
* 2005-10-18 21:31:16.002 Authentication log (see session log for details):
* 2005-10-18 21:31:16.002 Using username "rtablada".
* 2005-10-18 21:31:16.002 Access denied
* 2005-10-18 21:31:16.002
* 2005-10-18 21:31:16.002 Unable to authenticate

Reply with quote

Advertisement

richdog
Guest

Has your password changed recently? It sounds as if you have a stored password somewhere in WinSCP that is no longer valid, or your password on your SSH server is no longer valid.

Reply with quote

carolathompson
Joined:
Posts:
1

password trouble

I have a somewhat different version of this problem. I just changed several Unix server passwords yesterday. I can now telnet into these servers, but both WinSCP and Putty give me authentication errors on these same servers. Do they have trouble with special characters in passwords? I was using "!" in my passwords and I just changed it.
_________________
Carol A Thompson
carolt@wellsfargo.com

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,069
Location:
Prague, Czechia

Re: password trouble

Check the SSH server log file.
_________________
Martin Prikryl

Reply with quote

Advertisement

Noname
Guest

Re: Session password issues

d_original wrote:

PS:before i got this problem i entered the login details and save the session now when i try to login it keeps asking for the session password which i entered same as the login password.

In my case, the problem was fixed by changing the preferred protocol number from 1 to 2 in WinSCP. Perhaps v.1 is no longer supported by default in SUSE Linux 9.3.

Reply with quote

Guest

Re: Session password issues

Noname wrote:

d_original wrote:

PS:before i got this problem i entered the login details and save the session now when i try to login it keeps asking for the session password which i entered same as the login password.

In my case, the problem was fixed by changing the preferred protocol number from 1 to 2 in WinSCP. Perhaps v.1 is no longer supported by default in SUSE Linux 9.3.

I had a similar problem when I upgraded SUSE. I could login with Puty but not SCP. Changing SSH protocol from 1 to 2 fixed my problem also. Thanks.

Reply with quote

Pythagoras1
Guest

still no luck

still no luck with all the hints :(
i even tried to set the password on the server again and changing protocol and encryption did not make a difference. winscp keeps asking me for a session password while putty works.

here is the client log:

. --------------------------------------------------------------------------
. WinSCP Version 2.0.0 (Build 110)
. Login time: Freitag, 09. Februar 2007 20:13:43
. --------------------------------------------------------------------------
. Session name: mayly@192.168.0.73
. Host name: 192.168.0.73 (Port: 22)
. User name: mayly (Password: Yes, Key file: No)
. SSH protocol version: 2; Compression: No
. Agent forwarding: No; TIS/CryptoCard authentication: No
. Imitate SSH2 MAC bug: No; Cipher: 3des
. Ping interval: 0 min (0 = off)
. Return code variable: Autodetect; Lookup user groups: Yes
. Shell: default, EOL: 0
. Local directory: default, Remote directory: home, Update: No
. Clear aliases: Yes, Unset nat.vars: Yes
. Alias LS: No, Ign LS warn: Yes, Scp1 Comp: No
. --------------------------------------------------------------------------
. Server version: SSH-2.0-OpenSSH_4.5
. We claim version: SSH-2.0-PuTTY
. Using SSH protocol version 2
. Host key fingerprint is:
. 1024 a1:38:ed:39:3d:2d:f5:3d:4d:f2:dc:44:b2:c9:71:ad
. Initialised triple-DES client->server encryption
. Initialised triple-DES server->client encryption
! Access denied
. Authentication refused
! Access denied
. Authentication refused
! Access denied
. Authentication refused
. No more passwords to try

I set the ssh daemon on the server on its highest debug level "DEBUG3" and this is what i got when connecting. this is the server log:

debug3: fd 4 is not O_NONBLOCK
debug1: rexec start in 4 out 4 newsock 4 pipe 6 sock 7
debug1: Forked child 8636.
debug3: send_rexec_state: entering fd = 7 config len 215
debug3: ssh_msg_send: type 0
debug3: send_rexec_state: done
debug1: inetd sockets after dupping: 3, 3
Connection from 192.168.0.1 port 4272
debug1: Client protocol version 2.0; client software version PuTTY
debug1: no match: PuTTY
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug2: fd 3 setting O_NONBLOCK
debug2: Network child is on pid 8640
debug3: preauth child monitor started
debug3: mm_request_receive entering
debug3: monitor_read: checking request 4
debug3: mm_answer_sign
debug3: mm_answer_sign: signature 0x56b210(55)
debug3: mm_request_send entering: type 5
debug2: monitor_read: 4 used once, disabling now
debug3: mm_request_receive entering
debug3: monitor_read: checking request 6
debug3: mm_answer_pwnamallow
debug3: Trying to reverse map address 192.168.0.1.
debug2: parse_server_config: config reprocess config len 215
debug3: mm_answer_pwnamallow: sending MONITOR_ANS_PWNAM: 1
debug3: mm_request_send entering: type 7
debug2: monitor_read: 6 used once, disabling now
debug3: mm_request_receive entering
debug3: monitor_read: checking request 45
debug1: PAM: initializing for "mayly"
debug1: PAM: setting PAM_RHOST to "192.168.0.1"
debug1: PAM: setting PAM_TTY to "ssh"
debug2: monitor_read: 45 used once, disabling now
debug3: mm_request_receive entering
debug3: monitor_read: checking request 3
debug3: mm_answer_authserv: service=ssh-connection, style=
debug2: monitor_read: 3 used once, disabling now
debug3: mm_request_receive entering

this is where winscp permanently asks for a password but no password attempts are shown in the log file. when i press cancel the log just gives me one single line:

debug1: do_cleanup

that's all, no error, nothing. i already tried an other username. also checked the config:

Subsystem sftp /usr/lib64/misc/sftp-server

this looks like winscp doesn't even send any password and thinks it was wrong or something like that.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,069
Location:
Prague, Czechia

Re: still no luck

Pythagoras1 wrote:

still no luck with all the hints :(
i even tried to set the password on the server again and changing protocol and encryption did not make a difference. winscp keeps asking me for a session password while putty works.
Please download the recent version of WinSCP. (For short time, very ancient version was linked from download page by mistake).
_________________
Martin Prikryl

Reply with quote

Advertisement

isma44
Guest

I solved this problem with the restarting of SFTP service.

My SFTP server is running on the Windows.

I was suffering the same problem...
but I solved this problem,
with the restarting of SFTP service.

FYI, my SFTP service is freeFTPd.

Reply with quote

Advertisement

You can post new topics in this forum