WebDav authentication (Windows) not working

Advertisement

kwaclawek
Guest

WebDav authentication (Windows) not working

I set up a WebDav server on Windows using IIS 8.5.

I can access the authorized directories without problems using Windows Explorer or Cyberduck.

However, WinSCP seems unable to negotiate the 401 challenge. It does not even get to the password prompt, i get two error messages with the same text:
Authentication failed.
Could not authenticate to server: ignored Negotiate challenge, ignored NTLM challenge
This happens on port 80 and also port 443 (SSL).

See attached log file (level Debug1).

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,398
Location:
Prague, Czechia

Re: WebDav authentication (Windows) not working

Thanks for your report.

Is the wiki.qlinesolutions.com real? I cannot resolve the host name.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

kwaclaw
Joined:
Posts:
1
Location:
Canada

Re: WebDav authentication (Windows) not working

This is an internal web site, not publicly accessible. Problem is the same if used through VPN.

I sent you the requested email.

Karl

Reply with quote

migglezimblatt
Guest

still seems to be an issue in 2020

exactly the same symptoms, even after switching the web server to basic authentication

Reply with quote

migglezimblatt
Guest

log file for the current problem (all help appreciated)

2020-12-17 12:59:44.408 Doing DNS lookup on [REDACTED]
. 2020-12-17 12:59:44.408 req: Connecting to [REDACTED]:80
. 2020-12-17 12:59:44.423 Request sent; retry is 0.
. 2020-12-17 12:59:44.423 [status-line] < HTTP/1.1 401 Unauthorized
. 2020-12-17 12:59:44.423 Header Name: [cache-control], Value: [no-cache, no-store, must-revalidate]
. 2020-12-17 12:59:44.423 Header Name: [pragma], Value: [no-cache]
. 2020-12-17 12:59:44.423 Header Name: [content-type], Value: [text/html]
. 2020-12-17 12:59:44.423 Header Name: [expires], Value: [-1]
. 2020-12-17 12:59:44.423 Header Name: [server], Value: [Microsoft-IIS/10.0]
. 2020-12-17 12:59:44.423 Header Name: [www-authenticate], Value: [NTLM]
. 2020-12-17 12:59:44.423 Header Name: [x-powered-by], Value: [ASP.NET]
. 2020-12-17 12:59:44.423 Header Name: [x-ua-compatible], Value: [IE=11]
. 2020-12-17 12:59:44.423 Header Name: [date], Value: [Thu, 17 Dec 2020 12:59:44 GMT]
. 2020-12-17 12:59:44.423 Header Name: [content-length], Value: [1293]
. 2020-12-17 12:59:44.423 End of headers.
. 2020-12-17 12:59:44.439 ah_post_send (#0), code is 401 (want 401), WWW-Authenticate is NTLM
. 2020-12-17 12:59:44.439 auth: Got challenge (code 401).
. 2020-12-17 12:59:44.439 auth: No challenges accepted.
. 2020-12-17 12:59:44.439 Request ends, status 401 class 4xx, error line:
. 2020-12-17 12:59:44.439 Could not authenticate to server: ignored NTLM challenge
. 2020-12-17 12:59:44.439 Request ends.
. 2020-12-17 12:59:44.439 sess: Destroying session.
. 2020-12-17 12:59:44.439 sess: Closing connection.
. 2020-12-17 12:59:44.439 sess: Connection closed.
* 2020-12-17 12:59:44.439 (EFatal) Authentication failed.
* 2020-12-17 12:59:44.439 Could not authenticate to server: ignored NTLM challenge
* 2020-12-17 12:59:44.439 Connection failed.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: still seems to be an issue in 2020

migglezimblatt wrote:

exactly the same symptoms, even after switching the web server to basic authentication
Please attach a complete session log file for the basic authentication.

Reply with quote

Advertisement

You can post new topics in this forum