Problems w setting-up SFTP connection (FTP works)

Advertisement

JosdeDuiksmurf
Joined:
Posts:
1
Location:
Netherlands

Problems w setting-up SFTP connection (FTP works)

Hi,
After spending hours trying to find the solution myself, I decided to sign up in this forum. Situation: I have a Zyxel NAS520 (behind a Netgear router) which I want to connect from another location for safe file transfer. I downloaded the latest version of WinSCP and configured my NAS to include SSH service. Acc. WinSCP info this seems to be done properly (availabe protocols are transfer protocol SFTP-3, cryptographic protocol SSH-2, OpenSSH_6.7).
Next step was to connect to the NAS from my PC. I started using FTP login and could see and access the complete folder structure on my NAS. As expected. Next step was to login via SFTP and here I stumbled into the first issue: the displayed folder-structure of the NAS is completely different/unexpected: only a /Home/* folder w some sub folders, one for each NAS user (created some time ago). That's it. Not the existing folder structure on my NAS w all my files. I think I am missing something related to the certificates or so (handshake?), because the FTP login seems to work as expected. I hope someone can shed some light what is missing.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,563
Location:
Prague, Czechia

Re: Problems w setting-up SFTP connection (FTP works)

This is hardly related to "certificates" or any "handshake".

Anyway, I'm afraid that this forum is not right place to solve your problem. Unless any other SFTP client works differently.

Reply with quote

Advertisement

You can post new topics in this forum