chmod does not work

Advertisement

strange
Guest

chmod does not work

I just used Winscp 3.76 and an older Version 3.1.0 to set file and folder permissions

This does not seem to work. I can change by right clicking ang choosing chmod 777 them and in winscp it seems that the permissions were changed. So far everything seems to be all right. Next to the file winscp shows that the permissions were changed to rwxrwxrwx. however the problem is that I still get the error message that the file is not writable and that I have to chmod config.php to 666 and some directories to 777 during my postnuke installation procedure.
How is that possible?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,502
Location:
Prague, Czechia

Re: chmod does not work

What permissions do you see if you list the directory from terminal?
_________________
Martin Prikryl

Reply with quote

strange
Guest

The config.php file I chmodded to 666 was set to -rw-rw-rw- according to the terminal. The directores I chmodded to 777 were set to drwxrwxrwx according to the terminal. But doesnt that mean that permissions were set correctly. But the problem is that I still get error messages that the directory/file is not writable. And postnuke chmod check is still telling me, I have to chmod the config.php to 666 and some temporary directories to 777.

Reply with quote

strange
Guest

well after spending lot of time for this issue I finally found this thread.

<invalid hyperlink removed by admin>

I have not yet solved the problem but at least it seems that I found the reason for it. So it seems like winscp was not guilty. The problem seems to be caused by sourceforge.net

Reply with quote

Advertisement

You can post new topics in this forum