Topic "get -delete not working"

Author Message
tech543

Guest


I currently have a winscp script to download any zip files from a remote location that was added within the last 30 minutes. I need to have these files deleted after a successful download but
for some reason get - delete is not working. Anybody have any suggestions?

Here is the cmd being used:

cd /remotedirectory
lcd C:\localdirectory

get -delete -filemask="*>30N" /remotedirectory*.zip

exit

NOTE: I have the script working without -delete. when adding -delete, zip files still transfer but do not delete afterwards from the remote directory.
martin◆
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26890
Location: Prague, Czechia
Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Advertisements

You can post new topics in this forum

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License