Problem with Unicode in the WinSCP internal editor

Advertisement

Guest

Problem with Unicode in the WinSCP internal editor

Hello,
there is a Problem with one Unicode character with the WinSCP internal editor.

My workaround:
- display the character with the HTML hexadecimal code in a webbrowser.
- copy&paste the character into OpenOffice Calc.
- copy&paste the character into notepad++
- copy&paste the character into the WinSCP internal editor
than, the Unicode character "1D5BC" don't display, but a range of 1023 other characters displaying correctly.

HTML is UTF-8
<html lang="en">
<head>
<meta charset="UTF-8">

OpenOffice import with Unicode (UTF-8)

notepad++ is set UTF-8

WinSCP internal editor encoding is set UTF-8


https://ibb.co/buBCa6


https://ibb.co/hF33hm

When i edit the *.html file in notepadd++ local and upload it, there is no problem with this character.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problem with Unicode in the WinSCP internal editor

Thanks for your report.
I will take a look at this issue.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Problem with Unicode in the WinSCP internal editor

This issue has been added to the tracker:
https://winscp.net/tracker/show_bug.cgi?id=1580

Thanks for your report.

Can you send me an email, so I can send you back a development version of WinSCP for testing? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

You can post new topics in this forum