All uploads lack permission

Advertisement

DSMatichuk
Joined:
Posts:
1
Location:
Canada

All uploads lack permission

All uploads with WinSCP are uploaded without proper permissions for some reasons. It's extremely time consuming to have to change permissions on thousands of files a day. Why can't they just inherit permissions from their parent directory?

Also, why does the properties dialog have options for Group and User permissions in 2 locations independently? It doesn't make sense. Even if I set the Group and user permissions to 755 I still have to set the group and user permissions in the drop down boxes above. I don't understand what that's about. Please help me understand this.

Description: Notice the root[0] permissions. I have to change that for every upload. Why can't it be set to parent permissions on upload?

permissions.JPG

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,426
Location:
Prague, Czechia

Re: All uploads lack permission

Sorry, but this is too broad question. A complete session log file would help.

Make sure you did not enable "Set permissions" option in transfer settings.
https://winscp.net/eng/docs/ui_transfer_custom

I'm not sure what you refer to by "2 locations".
There are ownership boxes (where you specify a username and group name).
And there's permissions box.

If your uploaded files get owned by "root", while you want them owned by a specific account, it must be because you are logging in as the root. Make sure you login using the account you want to own the files.

Reply with quote

Advertisement

You can post new topics in this forum