Support .NET 4.5

Advertisement

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,671
Location:
Prague, Czechia

Re: Support .NET 4.5

Can you explain why an assembly compiled against .NET 2.0 cannot work with SSIS 2017?

Reply with quote

BAlexandrov
Joined:
Posts:
4
Location:
Bulgaria

It have me very strange error - "Exception has been thrown by the target of an invocation" that went away after recompiling it from the source with target 4.5 but may be some side effect hmm...

Reply with quote

BAlexandrov
Joined:
Posts:
4
Location:
Bulgaria

Got it, false alarm.

The error is:
---------------
Exception has been thrown by the target of an invocation
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at Microsoft.SqlServer.Dts.Tasks.ScriptTask.VSTATaskScriptingEngine.ExecuteScript()
--------------

The SSIS catch here is - when the dll version is upgraded, the script task is still compiled with the old one and gave me that strange error. This get fixed with just open the script and saving it. And also the version that is referenced in the script project and the one in GAC must be the same.

Keep up the good work!

Reply with quote

Advertisement

You can post new topics in this forum